aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax P <maxp@pdx.edu>2016-09-23 11:15:28 -0700
committerGitHub <noreply@github.com>2016-09-23 11:15:28 -0700
commit433dd00b93e62bd051c60df03c0894fcb44dffcd (patch)
tree250325b196637062648c27080df30161b89fb8a3
parent0fd0fa084be615256770251c11e6e4bc948e7456 (diff)
parentdd1c2f99739147ab560bf2a9c3f722e86f7ad6a7 (diff)
downloadprofanity-433dd00b93e62bd051c60df03c0894fcb44dffcd.tar.gz
profanity-433dd00b93e62bd051c60df03c0894fcb44dffcd.tar.xz
Merge pull request #1 from kennyballou/update-prof
Update Profanity and LIbstophe to new versions
-rw-r--r--dev-libs/libstrophe/Manifest1
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.1.ebuild45
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.5.0.ebuild44
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
index 5902758..deabcbb 100644
--- a/dev-libs/libstrophe/Manifest
+++ b/dev-libs/libstrophe/Manifest
@@ -1 +1,2 @@
DIST 0.8.8.tar.gz 128385 SHA256 08f4a85ef419a8bdf08b6afa8f7b2a0e5e180fdc9c16cede81af672ec10e21e7 SHA512 fe1e9ee0ea93271862ca8bd3cd5cd66d0bd060398f3b11a242158872501ab517f4f436e474dd5603d73433333d4aaf0957d68b7fe69578d7d99541aaa63a38a3 WHIRLPOOL 684ecd641c8b8bac92218dc551f9fa1f5e42148cc832e43db2a5accee014d84a00899da05d41e75572a0102dfe139e165092f46e1e8866a7003f852e8ed6bdb7
+DIST 0.9.1.tar.gz 153142 SHA256 c90493f986e5bd407132c5a3e174378c02cb80fa4eaee29875e06b4bba6afcc3 SHA512 4ae0ea7ad21fc566dc5372b1b6ed1dd47da87dadeb5771bb85c51b9119d781b7ec8e2b89d056cbfe81968a7f7db6d93fed435f28d28e552b9e61d5ffdddd4916 WHIRLPOOL 44bc91bfa90d56265ef97c6c54b020372ebcf8907fd530385a5c6a36c2e598d22435a0fafc7c59505a703fa9db210aec752b72ac89f93f619d7e20c8b6ae35e8
diff --git a/dev-libs/libstrophe/libstrophe-0.9.1.ebuild b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
new file mode 100644
index 0000000..067f348
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
+}
+src_compile() {
+ emake
+ use doc && doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc -r docs/html
+}
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index d4bb5f2..44e757d 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1 +1,2 @@
DIST profanity-0.4.7.tar.gz 463291 SHA256 b02c4e029fe84941050ccab6c8cdf5f15df23de5d1384b4d1ec66da6faee11dd SHA512 805adddbdf41334a2903707ce871f39c36c70639dc4c872cfd36769af36aa3597b05aa9ba719452bcbe8011cc73ac717cee7016c928083cd46c922732ca10568 WHIRLPOOL f58b903bbc8fa4cff734e66ce0e9744c8e7df85cafcb2398b616b63333c36c65c5925a301444da544b8bf7d154f0a221792b1c910b5534c81fb9a956d5341923
+DIST profanity-0.5.0.tar.gz 687169 SHA256 783be8aa6eab7192fc211f00adac136b21e580ea52d9c07128312a9609939668 SHA512 65625f0ed0b1e87c6cd4ec9dc85076a971b899b9b39d5707d32d1977a450b910ff760e339bfacd0d0906740bd299c018877b6720071d92c805fca095631e7163 WHIRLPOOL a6f748d7e34f2d355e9b2308f4d9cecbee12804de182b6cc5f138795a01541fc36835d10e79a21c8f925e99fd1a1a0bc4b8303aa224dd3f13bd98919d4f09df2
diff --git a/net-im/profanity/profanity-0.5.0.ebuild b/net-im/profanity/profanity-0.5.0.ebuild
new file mode 100644
index 0000000..80951bf
--- /dev/null
+++ b/net-im/profanity/profanity-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.profanity.im/"
+SRC_URI="http://www.profanity.im/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify otr pgp +themes xml xscreensaver"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=dev-libs/libstrophe-0.9.1[xml=]
+ net-misc/curl
+ sys-libs/ncurses
+ sys-libs/readline
+ pgp? ( app-crypt/gpgme )
+ otr? ( net-libs/libotr )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable pgp) \
+ $(use_with themes) \
+ $(use_with xml libxml2) \
+ $(use_with xscreensaver)
+}
+
+pkg_postinst() {
+ elog
+ elog "User guide is available online:"
+ elog " http://www.profanity.im/userguide.html"
+ elog
+}