aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax P <maxp@pdx.edu>2017-02-02 10:08:35 -0800
committerGitHub <noreply@github.com>2017-02-02 10:08:35 -0800
commit5e35670ff9d9ae16cecd62f36fcb880be400eab3 (patch)
tree58fc680f4219e5dcfe88225929e4ed8740438746
parent433dd00b93e62bd051c60df03c0894fcb44dffcd (diff)
parent070488fdc96b61a70ab60daf5f43ed3abadd6c6d (diff)
downloadprofanity-5e35670ff9d9ae16cecd62f36fcb880be400eab3.tar.gz
profanity-5e35670ff9d9ae16cecd62f36fcb880be400eab3.tar.xz
Merge pull request #2 from kennyballou/0.5.1HEADmaster
Add 0.5.1 release of profanity
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.5.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 44e757d..f7c7ba5 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,2 +1,3 @@
DIST profanity-0.4.7.tar.gz 463291 SHA256 b02c4e029fe84941050ccab6c8cdf5f15df23de5d1384b4d1ec66da6faee11dd SHA512 805adddbdf41334a2903707ce871f39c36c70639dc4c872cfd36769af36aa3597b05aa9ba719452bcbe8011cc73ac717cee7016c928083cd46c922732ca10568 WHIRLPOOL f58b903bbc8fa4cff734e66ce0e9744c8e7df85cafcb2398b616b63333c36c65c5925a301444da544b8bf7d154f0a221792b1c910b5534c81fb9a956d5341923
DIST profanity-0.5.0.tar.gz 687169 SHA256 783be8aa6eab7192fc211f00adac136b21e580ea52d9c07128312a9609939668 SHA512 65625f0ed0b1e87c6cd4ec9dc85076a971b899b9b39d5707d32d1977a450b910ff760e339bfacd0d0906740bd299c018877b6720071d92c805fca095631e7163 WHIRLPOOL a6f748d7e34f2d355e9b2308f4d9cecbee12804de182b6cc5f138795a01541fc36835d10e79a21c8f925e99fd1a1a0bc4b8303aa224dd3f13bd98919d4f09df2
+DIST profanity-0.5.1.tar.gz 691508 SHA256 e3513713e74ec3363fbdbac2919bdc17e249988780cc5a4589d1425807a7feb8 SHA512 fcafa7e1dcf0948d7fa30ba33665e1ec0e8bb9e0246df2d1cf3fe5d7f2bd25b07fa2cb0fd383ee23fc720850ff295159537567f175c21f1c93f50da0099e209d WHIRLPOOL 17da0ae4088619dcf9d25552ed2f1f366ec03e61abf117c8cd5843244c751b9d732e4e47add5395f35fe1bf8845b562a1c23e5a7935b454ef1270ec7afc65aae
diff --git a/net-im/profanity/profanity-0.5.1.ebuild b/net-im/profanity/profanity-0.5.1.ebuild
new file mode 100644
index 0000000..80951bf
--- /dev/null
+++ b/net-im/profanity/profanity-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Ncurses based jabber client inspired by irssi"
+HOMEPAGE="http://www.profanity.im/"
+SRC_URI="http://www.profanity.im/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify otr pgp +themes xml xscreensaver"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=dev-libs/libstrophe-0.9.1[xml=]
+ net-misc/curl
+ sys-libs/ncurses
+ sys-libs/readline
+ pgp? ( app-crypt/gpgme )
+ otr? ( net-libs/libotr )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable pgp) \
+ $(use_with themes) \
+ $(use_with xml libxml2) \
+ $(use_with xscreensaver)
+}
+
+pkg_postinst() {
+ elog
+ elog "User guide is available online:"
+ elog " http://www.profanity.im/userguide.html"
+ elog
+}