aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkballou <kballou@devnulllabs.io>2016-09-20 19:43:21 -0600
committerkballou <kballou@devnulllabs.io>2016-09-23 10:07:28 -0600
commit6a2062f29aaf0c2bfa374fed3d512227abe9eb2d (patch)
treea2e763e3ee7a750dd3f7a2f7753db4bb093ca65b
parent0fd0fa084be615256770251c11e6e4bc948e7456 (diff)
downloadprofanity-6a2062f29aaf0c2bfa374fed3d512227abe9eb2d.tar.gz
profanity-6a2062f29aaf0c2bfa374fed3d512227abe9eb2d.tar.xz
Update libstrophe to 0.9.1
Updated to new release of [libstrophe][1]. [1]: https://github.com/strophe/libstrophe/blob/0.9.1/ChangeLog
-rw-r--r--dev-libs/libstrophe/Manifest1
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
index 5902758..deabcbb 100644
--- a/dev-libs/libstrophe/Manifest
+++ b/dev-libs/libstrophe/Manifest
@@ -1 +1,2 @@
DIST 0.8.8.tar.gz 128385 SHA256 08f4a85ef419a8bdf08b6afa8f7b2a0e5e180fdc9c16cede81af672ec10e21e7 SHA512 fe1e9ee0ea93271862ca8bd3cd5cd66d0bd060398f3b11a242158872501ab517f4f436e474dd5603d73433333d4aaf0957d68b7fe69578d7d99541aaa63a38a3 WHIRLPOOL 684ecd641c8b8bac92218dc551f9fa1f5e42148cc832e43db2a5accee014d84a00899da05d41e75572a0102dfe139e165092f46e1e8866a7003f852e8ed6bdb7
+DIST 0.9.1.tar.gz 153142 SHA256 c90493f986e5bd407132c5a3e174378c02cb80fa4eaee29875e06b4bba6afcc3 SHA512 4ae0ea7ad21fc566dc5372b1b6ed1dd47da87dadeb5771bb85c51b9119d781b7ec8e2b89d056cbfe81968a7f7db6d93fed435f28d28e552b9e61d5ffdddd4916 WHIRLPOOL 44bc91bfa90d56265ef97c6c54b020372ebcf8907fd530385a5c6a36c2e598d22435a0fafc7c59505a703fa9db210aec752b72ac89f93f619d7e20c8b6ae35e8
diff --git a/dev-libs/libstrophe/libstrophe-0.9.1.ebuild b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
new file mode 100644
index 0000000..067f348
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="MIT GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc xml"
+
+RDEPEND="xml? ( dev-libs/libxml2 )
+ !xml? ( dev-libs/expat )
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
+}
+src_compile() {
+ emake
+ use doc && doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc -r docs/html
+}