aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Parmer <maxp@trystero.is>2016-03-21 20:45:54 -0700
committerMax Parmer <maxp@trystero.is>2016-03-21 20:45:54 -0700
commitaaee88bdf074fedc451c8eb1bf201ee466c40778 (patch)
treeca6624fe509b8fd8163f22dab2c845b385945d65
parente050eec7d4fb4f96233b55b9cfdc75ff2bccda11 (diff)
downloadprofanity-aaee88bdf074fedc451c8eb1bf201ee466c40778.tar.gz
profanity-aaee88bdf074fedc451c8eb1bf201ee466c40778.tar.xz
dev-libs/libstrophe*: upgrade EAPI, style changes
-rw-r--r--dev-libs/libstrophe/libstrophe-0.8.8.ebuild23
-rw-r--r--dev-libs/libstrophe/libstrophe-9999.ebuild32
2 files changed, 30 insertions, 25 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.8.8.ebuild b/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
index 1f85e36..067f348 100644
--- a/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.8.8.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="http://strophe.im/libstrophe/"
@@ -22,19 +22,24 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
- use xml && econf $(use_with xml libxml2)
- # workaround for building with expat support
- use xml || econf
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
+}
+src_compile() {
+ emake
+ use doc && doxygen
}
src_install() {
emake DESTDIR="${D}" install
- if use doc; then
- doxygen || die
- fi
- use doc && dohtml -r docs/html/*
+ use doc && dodoc -r docs/html
}
diff --git a/dev-libs/libstrophe/libstrophe-9999.ebuild b/dev-libs/libstrophe/libstrophe-9999.ebuild
index 1aa5534..49a6ebc 100644
--- a/dev-libs/libstrophe/libstrophe-9999.ebuild
+++ b/dev-libs/libstrophe/libstrophe-9999.ebuild
@@ -2,47 +2,47 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-EGIT_REPO_URI="git://github.com/strophe/libstrophe.git"
-
-inherit autotools eutils git-2
+inherit autotools git-r3
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="http://strophe.im/libstrophe/"
+EGIT_REPO_URI="https://github.com/strophe/libstrophe.git git://github.com/strophe/libstrophe.git"
LICENSE="MIT GPL-3"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
IUSE="doc xml"
RDEPEND="xml? ( dev-libs/libxml2 )
!xml? ( dev-libs/expat )
- dev-libs/openssl"
+ dev-libs/openssl:0"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-S="${WORKDIR}/${P/-/_}"
+S="${WORKDIR}/${P}"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
- use xml && econf $(use_with xml libxml2)
- # workaround for building with expat support
- use xml || econf
+ if use xml; then
+ # defaults to expat otherwise
+ econf $(use_with xml libxml2)
+ else
+ econf
+ fi
}
-
src_compile() {
emake
- if use doc; then
- doxygen || die
- fi
+ use doc && doxygen
}
src_install() {
- einstall
+ emake DESTDIR="${D}" install
dodoc LICENSE.txt README.markdown
- use doc && dohtml -r docs/html/*
+ use doc && dodoc -r docs/html
}