aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/timew/Manifest1
-rw-r--r--app-misc/timew/metadata.xml15
-rw-r--r--app-misc/timew/timew-1.0.0.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
new file mode 100644
index 0000000..0ac9044
--- /dev/null
+++ b/app-misc/timew/Manifest
@@ -0,0 +1 @@
+DIST timew-1.0.0.tar.gz 140539 SHA256 ac027910e1e8365bdd218a8b42389b26d017d38d3c96516c408db6d5a44e0bb5 SHA512 0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5 WHIRLPOOL 77ede6c679203071c3da95f708326f626906266547301b9ce2f2c8ae768f6b4082fb32bcc325a22e7295f5894477786960632ff201771b3512d978bf8c379c75
diff --git a/app-misc/timew/metadata.xml b/app-misc/timew/metadata.xml
new file mode 100644
index 0000000..e3ef138
--- /dev/null
+++ b/app-misc/timew/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kballou@devnulllabs.io</email>
+ <name>Kenny Ballou</name>
+ </maintainer>
+ <longdescription lang="en">
+ Timewarrior tracks and reports time.
+ </longdescription>
+ <upstream>
+ <doc lang="en">http://taskwarrior.org/docs/timewarrior</doc>
+ <bugs-to>bug.tasktools.org</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/timew/timew-1.0.0.ebuild b/app-misc/timew/timew-1.0.0.ebuild
new file mode 100644
index 0000000..2e3d12f
--- /dev/null
+++ b/app-misc/timew/timew-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2016 Kenny Ballou
+# Distributed under the terms of the GNU General Public License v3
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils bash-completion-r1
+
+DESCRIPTION="Timewarrior tracks and reports time"
+HOMEPAGE="http://taskwarrior.org/docs/timewarrior/index.html"
+SRC_URI="http://taskwarrior.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/readline:0
+ elibc_glibc? ( sys-apps/util-linux )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # don't automatically install ext
+ sed -i '/ext/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}