summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..14c3264
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python
+
+import os
+import shutil
+from distutils.core import setup
+
+def read(fname):
+ return "\n" + open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+shutil.copy2("README.markdown", "README")
+
+setup(
+ name="Xnt",
+ version="0.1.0",
+ author="Kenny Ballou",
+ author_email="kennethmgballou@gmail.com",
+ url="https://bitbucket.org/devnulltao/xnt",
+ description=("High-Level build script for doing more complex build tasks"),
+ license="gpl3",
+ keywords="Build Scripts",
+ packages=["xnt",],
+ scripts=["Xnt.py",],
+ package_data={
+ },
+ long_description=read("README.markdown"),
+ platforms=["Linux",],
+)