summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:38:30 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:39:49 -0600
commit71d92fbd9c3166132b22e58ae178efec43f869a9 (patch)
treee7a3b525aeb6da1e1c7e1ef49e5c8864422585d5
parent3d5305fc8de29d02db96430db51c53ea6659977a (diff)
downloadguix-add-python-molecule.tar.gz
guix-add-python-molecule.tar.xz
wip: add more python packagesadd-python-molecule
break these up...
-rw-r--r--gnu/packages/python.scm204
1 files changed, 204 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 692626350c..5d1b056f92 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -74,6 +74,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages adns)
#:use-module (gnu packages attr)
#:use-module (gnu packages backup)
@@ -13947,6 +13948,37 @@ Let's Encrypt.")
development that supports command line argument parsing, command string
validation testing and application logic.")
(license license:expat)))
+
+(define-public python-coveralls
+ (package
+ (name "python-coveralls")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "coveralls" version))
+ (sha256
+ (base32
+ "0il3vac7pqnhivlm0jflsbh46zyqm5cn2izc8zip6mifims98iv6"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-mock" ,python-mock)
+ ("python-sh" ,python-sh)
+ ("python-coverage" ,python-coverage)))
+ (propagated-inputs
+ `(("python-pyyaml" ,python-pyyaml)))
+ (home-page
+ "https://github.com/coveralls-clients/coveralls-python")
+ (synopsis
+ "Show coverage stats online via coveralls.io")
+ (description
+ "@code{coveralls.io} is a service for publishing coverage states online.
+This package provides seamless integration with @code{coverage.py} (and thus
+@code{py.test}, @code{nosetests}, etc...) in Python projects.")
+ (license license:expat)))
+
(define-public python-typed-ast
(package
(name "python-typed-ast")
@@ -13970,6 +14002,94 @@ type comment support. Unlike @code{ast}, the parsers in @code{typed_ast}
include PEP-484 type comments and are independent of the version of Python
under which they are run.")
(license license:asl2.0)))
+
+(define-public python-mypy
+ (package
+ (name "python-mypy")
+ (version "0.620")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mypy" version))
+ (sha256
+ (base32
+ "0g1vxxf489vfx4lgf3qh12dycv53qyv382lz9q0lmpczaxd60w67"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-wheel" ,python-wheel)
+ ("python-attrs" ,python-attrs)
+ ("python-flake8" ,python-flake8)
+ ("python-flake8-bugbear" ,python-flake8-bugbear)
+ ("python-flake8-pyi" ,python-flake8-pyi)
+ ("python-lxml" ,python-lxml)
+ ("python-psutil" ,python-psutil)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-xdist" ,python-pytest-xdist)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-typed-ast" ,python-typed-ast)
+ ("python-py" ,python-py)
+ ("python-virtualenv" ,python-virtualenv)))
+ (home-page "http://www.mypy-lang.org/")
+ (synopsis "Optional static typing for Python")
+ (description
+ "@code{my[py]} is an optional static typing for Python. Add type hints
+to Python programs, and use @code{mypy} to type check them statically.")
+ (license '(license:expat license:psfl))))
+
+(define-public python-ruamel.yaml
+ (package
+ (name "python-ruamel.yaml")
+ (version "0.15.46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruamel.yaml" version))
+ (sha256
+ (base32
+ "1w4nlgkw4sq54vnddrbs39map1zk9bqyb0y2q99r79ccln2q014g"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-pytest" ,python-pytest)
+ ("python-mypy" ,python-mypy)))
+ (inputs
+ `(("python-configobj" ,python-configobj)))
+ (home-page "https://bitbucket.org/ruamel/yaml")
+ (synopsis
+ "YAML parser/emitter that supports roundtrip attribute preservation")
+ (description
+ "ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation
+of comments, seq/map flow style, and map key order")
+ (license license:expat)))
+
+(define-public python-ansible-lint
+ (package
+ (name "python-ansible-lint")
+ (version "3.4.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ansible-lint" version))
+ (sha256
+ (base32
+ "0mvsmfv5k6fb5q29rjdclpw9m2s8y5d4322p59b834mb9baxm1kn"))))
+ (build-system python-build-system)
+ (inputs
+ `(("ansible" ,ansible)))
+ (native-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-nose" ,python-nose)
+ ("python-pep8-naming" ,python-pep8-naming)
+ ("python-tox" ,python-tox)
+ ("python-wheel" ,python-wheel)))
+ (home-page
+ "https://github.com/willthames/ansible-lint")
+ (synopsis
+ "Ansible Playbook linting tool")
+ (description
+ "Checks playbooks for practices and behaviour that could be improved")
+ (license license:expat)))
+
(define-public python-cerberus
(package
(name "python-cerberus")
@@ -13995,3 +14115,87 @@ dictionaries.")
(define-public python2-cerberus
(package-with-python2 python-cerberus))
+
+(define-public python-anyconfig
+ (package
+ (name "python-anyconfig")
+ (version "0.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "anyconfig" version))
+ (sha256
+ (base32
+ "0zhfrvcszsmr0qdz5rdxcxf0qwf5743ax6byph1fbigcdsp1cq2d"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-jinja2" ,python-jinja2)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-configobj" ,python-configobj)
+ ("python-jmespath" ,python-jmespath)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-setuptools" ,python-setuptools)
+ ("python-toml" ,python-toml)))
+ (native-inputs
+ `(("python-coveralls" ,python-coveralls)
+ ("python-flake8" ,python-flake8)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-pycodesytle" ,python-pycodestyle)
+ ("python-pylint" ,python-pylint)))
+ (home-page
+ "https://github.com/ssato/python-anyconfig")
+ (synopsis
+ "Provides common APIs to read and write variaous configuration files")
+ (description
+ "Library provides common APIs to load and dump configuration files in
+various formats")
+ (license license:expat)))
+
+(define-public python-molecule
+ (package
+ (name "python-molecule")
+ (version "2.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "molecule" version))
+ (sha256
+ (base32
+ "1l2ghrlj9rpwapy3v4dmcrhgzhc2qr7vrwwa9fhns5hb4r1gp2bq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-ansible-lint" ,python-ansible-lint)
+ ("python-anyconfig" ,python-anyconfig)
+ ("python-cerberus" ,python-cerberus)
+ ("python-click-completion" ,python-click-completion)
+ ("python-click" ,python-click)
+ ("python-colorama" ,python-colorama)
+ ("python-cookiecutter" ,python-cookiecutter)
+ ("python-flake8" ,python-flake8)
+ ("python-gilt" ,python-gilt)
+ ("python-jinja2" ,python-jinja2)
+ ("python-pbr" ,python-pbr)
+ ("python-pexpect" ,python-pexpect)
+ ("python-psutil" ,python-psutil)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-sh" ,python-sh)
+ ("python-six" ,python-six)
+ ("python-tabulate" ,python-tabulate)
+ ("python-testinfra" ,python-testinfra)
+ ("python-tree-format"
+ ,python-tree-format)
+ ("python-yamllint" ,python-yamllint)))
+ (home-page
+ "https://github.com/metacloud/molecule")
+ (synopsis
+ "Molecule aids in the development and testing of Ansible roles")
+ (description
+ "Molecule is designed to aid in the development and testing of
+@code{Ansible} roles. Molecule provides support for testing with multiple
+instances, operating systems and distributions, virtualization providers, test
+frameworks and testing scenarios. Molecule is opinionated in order to
+encourage an approach that results in consistently developed roles that are
+well-written, easily understood and maintained.")
+ (license license:expat)))