summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-31 22:18:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-31 22:18:51 +0200
commit0d206dd054b74279838d44029c52a5f7663de189 (patch)
treed8dfca12db8417a998eef097e95f20d7a189c9e8
parent64ed4b6a271637bfbda464033590c1d2a5c33c3e (diff)
downloadguix-0d206dd054b74279838d44029c52a5f7663de189.tar.gz
guix-0d206dd054b74279838d44029c52a5f7663de189.tar.xz
gnu: lvm2: Fix static linking of dmeventd.
Fixes a regression introduced in a3ed69b694eab393129348bbabbed8c59bad3772 where dmeventd.static fails to link against libm and breaks "lvm2-static". * gnu/packages/patches/lvm2-static-link.patch: Patch make.tmpl.in.
-rw-r--r--gnu/packages/patches/lvm2-static-link.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/lvm2-static-link.patch b/gnu/packages/patches/lvm2-static-link.patch
index 6adf6891bb..eb7849a679 100644
--- a/gnu/packages/patches/lvm2-static-link.patch
+++ b/gnu/packages/patches/lvm2-static-link.patch
@@ -12,3 +12,14 @@ and libm via libdevmapper.a.
liblvm2cmd.a: $(top_builddir)/lib/liblvm-internal.a $(OBJECTS) lvmcmdlib.o lvm2cmd.o
cat $(top_builddir)/lib/liblvm-internal.a > $@
+--- a/make.tmpl.in 2018-07-31 22:00:39.969983104 +0200
++++ b/make.tmpl.in 2018-07-31 22:00:58.467613682 +0200
+@@ -53,7 +53,7 @@
+
+ LIBS = @LIBS@
+ # Extra libraries always linked with static binaries
+-STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS)
++STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS) $(M_LIBS)
+ DEFS += @DEFS@
+ # FIXME set this only where it's needed, not globally?
+ CFLAGS ?= @COPTIMISE_FLAG@ @CFLAGS@