summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2018-07-21 10:57:35 -0500
committerMarius Bakke <mbakke@fastmail.com>2018-07-29 23:33:40 +0200
commit1237653aa5c555bc6b621b6402b26064db2e668e (patch)
tree4cf9452e9a3acc2b2777c6d0370a6ec30278895d
parent253340dcc8c44acb4c687ebcc56e6f17167c5659 (diff)
downloadguix-1237653aa5c555bc6b621b6402b26064db2e668e.tar.gz
guix-1237653aa5c555bc6b621b6402b26064db2e668e.tar.xz
gnu: Add emacs-agda2-mode
* gnu/packages/agda.scm (emacs-agda2-mode): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/agda.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index d677bb7e53..df4968c445 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -20,6 +20,7 @@
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-web)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system haskell)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -97,3 +98,19 @@ such as Coq, Epigram and NuPRL.")
;; Agda is distributed under the MIT license, and a couple of
;; source files are BSD-3. See LICENSE for details.
(license (list license:expat license:bsd-3))))
+
+(define-public emacs-agda2-mode
+ (package
+ (inherit agda)
+ (name "emacs-agda2-mode")
+ (build-system emacs-build-system)
+ (inputs '())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-elisp-dir
+ (lambda _ (chdir "src/data/emacs-mode") #t)))))
+ (home-page "https://agda.readthedocs.io/en/latest/tools/emacs-mode.html")
+ (synopsis "Emacs mode for Agda")
+ (description "This Emacs mode enables interactive development with
+Agda. It also aids the input of Unicode characters.")))