summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-07-31 15:42:16 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:39:49 -0600
commit1d06b6b03e00b7d8043f6cf33cae6364a5a57ff2 (patch)
tree73a93a91a1130a51eca2765f766ff7ef9fe4f26f
parentad3ea9d89ec604a41facfda6e881726b18b5bc06 (diff)
downloadguix-1d06b6b03e00b7d8043f6cf33cae6364a5a57ff2.tar.gz
guix-1d06b6b03e00b7d8043f6cf33cae6364a5a57ff2.tar.xz
gnu: add python-flake8-bugbear.
* gnu/packages/python.scm: (python-flake8-bugbear): New variable. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bffc52476b..072c8bb1f1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5834,6 +5834,32 @@ plugins that intend to support Flake8 2.x and 3.x simultaneously.")
(define-public python2-flake8-polyfill
(package-with-python2 python-flake8-polyfill))
+(define-public python-flake8-bugbear
+ (package
+ (name "python-flake8-bugbear")
+ (version "18.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-bugbear" version))
+ (sha256
+ (base32
+ "0y0mx9k556nkfsfigjyynacd638f0dqcjychps9cnacf8nfsj52z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-flake8" ,python-flake8)))
+ (home-page
+ "https://github.com/PyCQA/flake8-bugbear")
+ (synopsis
+ "Plugin to @code{flake8} for finding likely bugs and design problems")
+ (description
+ "A plugin for @code{flake8} finding likely bugs and design problems in
+your program. Contains warnings that don't belong in @code{pyflakes} and
+@code{pycodestyle}.")
+ (license license:expat)))
+
+
(define-public python-mistune
(package
(name "python-mistune")