summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-29 21:32:50 -0400
committerMark H Weaver <mhw@netris.org>2018-05-08 19:00:08 -0400
commit903874328ed5e5ab766e36cee1b1a0989e8b24a9 (patch)
tree2208dbca179f93c0d96792d25fd438e374ae7dab
parentaedc6e9fc952665e666f2febfc0b37235ad850ff (diff)
downloadguix-903874328ed5e5ab766e36cee1b1a0989e8b24a9.tar.gz
guix-903874328ed5e5ab766e36cee1b1a0989e8b24a9.tar.xz
gnu: gjs: Fix build.
* gnu/packages/gnome.scm (gjs)[native-inputs]: Add gcc-7. [arguments]: Add 'work-around-gcc-7-include-path-issue' phase.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6d0ec58c19..8c694c75c7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages game-development)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -4618,6 +4619,14 @@ configuration program to choose applications starting on login.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'set-paths 'work-around-gcc-7-include-path-issue
+ ;; FIXME: Work around a problem with gcc-7 includes (see
+ ;; <https://bugs.gnu.org/30756>). Note that we use gcc-7
+ ;; to work around an internal compiler error in gcc-5.
+ (lambda _
+ (unsetenv "C_INCLUDE_PATH")
+ (unsetenv "CPLUS_INCLUDE_PATH")
+ #t))
(add-before
'check 'pre-check
(lambda _
@@ -4635,7 +4644,11 @@ configuration program to choose applications starting on login.")
((".*expect\\(datestr\\).*") ""))
#t)))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-resources
+ `(("gcc" ,gcc-7) ; FIXME: Work around an internal compiler error in
+ ; gcc-5. Try removing this when our default compiler is
+ ; no longer gcc-5.5.0, and also remove the
+ ; 'work-around-gcc-7-include-path-issue' phase above.
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)
;; For testing