summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-05-30 13:17:53 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-30 21:51:43 +0200
commita3ed69b694eab393129348bbabbed8c59bad3772 (patch)
tree2cdb9f07d5a660843747e1e7975b813b97e0f5be
parentc229fb3d8813d2941d3fceaf1c196337f9e97de6 (diff)
downloadguix-a3ed69b694eab393129348bbabbed8c59bad3772.tar.gz
guix-a3ed69b694eab393129348bbabbed8c59bad3772.tar.xz
gnu: lvm2: Add device-mapper-event support.
* GNU/packages/linux.scm (lvm2)[configure-flags]: Build device-mapper-event.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f1bf65d27a..61f44100bf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2127,12 +2127,24 @@ time.")
"--enable-udev_sync"
"--enable-udev_rules"
"--enable-pkgconfig"
+ "--enable-cmdlib"
+ "--enable-dmeventd" ; Requires '--enable-cmdlib'.
;; Make sure programs such as 'dmsetup' can
;; find libdevmapper.so.
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
- "/lib"))
+ "/lib,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib/device-mapper")
+ ;; TODO: Patch make.tmpl.in to take LDFLAGS
+ ;; into account so that we don't need to also
+ ;; set CLDFLAGS.
+ (string-append "CLDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib/device-mapper"))
;; The tests use 'mknod', which requires root access.
#:tests? #f))