summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:14:48 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:39:49 -0600
commitd2f070e31ceedb610ac81656d3bafe945910fd1c (patch)
treefdc28f9222d7eb7b5b443325d6d27837af9994e5
parent1d06b6b03e00b7d8043f6cf33cae6364a5a57ff2 (diff)
downloadguix-d2f070e31ceedb610ac81656d3bafe945910fd1c.tar.gz
guix-d2f070e31ceedb610ac81656d3bafe945910fd1c.tar.xz
gnu: add python-flake8-pyi.
* gnu/packages/python.scm: (python-flake8-pyi): New variable. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 072c8bb1f1..692626350c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5859,6 +5859,34 @@ your program. Contains warnings that don't belong in @code{pyflakes} and
@code{pycodestyle}.")
(license license:expat)))
+(define-public python-flake8-pyi
+ (package
+ (name "python-flake8-pyi")
+ (version "18.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-pyi" version))
+ (sha256
+ (base32
+ "0m4sgnypgiq1hb0jwl0zpqmdx505bz76n6pcpj4vi8qq252f4rry"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-flake8" ,python-flake8)
+ ("python-mccabe" ,python-mccabe)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-pyflakes" ,python-pyflakes)))
+ (arguments
+ ;; FIXME: Enable tests when https://github.com/ambv/flake8-pyi/pulls/13
+ ;; is merged and https://github.com/ambv/flake8-pyi/issues/14 is closed.
+ '(#:tests? #f))
+ (home-page "https://github.com/ambv/flake8-pyi")
+ (synopsis
+ "Plugin to @code{flake8} to lint @code{.pyi} files")
+ (description
+ "A plugin for @code{flake8} to enable linting @code{.pyi} files.")
+ (license license:expat)))
(define-public python-mistune
(package