summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:53:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:16 +0200
commit14a671d8f9e628e06b40356b9a505df94eb89154 (patch)
treef824638b211ab996731db11b5f94b19b10a57f65
parente1dd78f68a8e0f29c416b5b7b1bbe5dc2cd610fb (diff)
downloadguix-14a671d8f9e628e06b40356b9a505df94eb89154.tar.gz
guix-14a671d8f9e628e06b40356b9a505df94eb89154.tar.xz
gnu: Add java-httpcomponents-httpclient.
* gnu/packages/java.scm (java-httpcomponents-httpclient): New variable.
-rw-r--r--gnu/packages/java.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4716759860..b3c1cb9814 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2113,6 +2113,42 @@ NIO.")))
(description "This package provides the HttpCore benchmarking tool. It is
an Apache AB clone based on HttpCore.")))
+(define-public java-httpcomponents-httpclient
+ (package
+ (name "java-httpcomponents-httpclient")
+ (version "4.5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/httpcomponents/httpclient/"
+ "source/httpcomponents-client-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "1428399s7qy3cim5wc6f3ks4gl9nf9vkjpfmnlap3jflif7g2pj1"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "httpcomponents-httpclient.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "httpclient") #t)))))
+ (inputs
+ `(("java-commons-logging-minimal" ,java-commons-logging-minimal)
+ ("java-commons-codec" ,java-commons-codec)
+ ("java-hamcrest-core" ,java-hamcrest-core)
+ ("java-httpcomponents-httpcore" ,java-httpcomponents-httpcore)
+ ("java-mockito" ,java-mockito-1)
+ ("java-junit" ,java-junit)))
+ (home-page "https://hc.apache.org/httpcomponents-client-ga/")
+ (synopsis "HTTP client library for Java")
+ (description "Although the @code{java.net} package provides basic
+functionality for accessing resources via HTTP, it doesn't provide the full
+flexibility or functionality needed by many applications. @code{HttpClient}
+seeks to fill this void by providing an efficient, up-to-date, and
+feature-rich package implementing the client side of the most recent HTTP
+standards and recommendations.")
+ (license license:asl2.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")