summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-21 01:07:17 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-21 01:17:11 +0200
commit324499184a13e8f27d9805d5db2b133380e69bfe (patch)
tree906dea95394548a4d24d9e0d26ab2de44a84af96
parenta588e34e0defcb5fde48570cf3a304cb942bf743 (diff)
downloadguix-324499184a13e8f27d9805d5db2b133380e69bfe.tar.gz
guix-324499184a13e8f27d9805d5db2b133380e69bfe.tar.xz
gnu: unionfs-fuse-static: Remove 'unionfsctl' executable.
This avoids pulling in glibc & co. Fixes a regression introduced in 2f861edf5cf5118ad560737343312c9a5efe5b2f (the 'unionfsctl' executable did not exist in unionfs-fuse 0.26). * gnu/packages/linux.scm (unionfs-fuse/static)[arguments] <post-install>: Remove 'unionfsctl' binary.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7bb26c72f5..cd2c833e39 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1568,7 +1568,12 @@ UnionFS-FUSE additionally supports copy-on-write.")
(exe (string-append out "/bin/unionfs")))
;; By default, 'unionfs' keeps references to
;; $glibc/share/locale and similar stuff. Remove them.
- (remove-store-references exe)))
+ (remove-store-references exe)
+
+ ;; 'unionfsctl' has references to glibc as well. Since
+ ;; we don't need it, remove it.
+ (delete-file (string-append out "/bin/unionfsctl"))
+ #t))
%standard-phases)))
(inputs `(("fuse" ,fuse-static)))))