summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-03-15 21:05:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 21:22:06 +0200
commit504c285d1092c9b7a2ef25c7a436da02bef70dc2 (patch)
tree9a87a5f5452bfa65b5fb995906fc68716340f4e7
parent9fdda0b2f83e7be1a0e1349b12d212805b7a8a97 (diff)
downloadguix-504c285d1092c9b7a2ef25c7a436da02bef70dc2.tar.gz
guix-504c285d1092c9b7a2ef25c7a436da02bef70dc2.tar.xz
gnu: Add dcmtk.
* gnu/packages/image-processing.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image-processing.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index be818604f7..067f6b0593 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -194,6 +194,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/idris.scm \
%D%/packages/idutils.scm \
%D%/packages/image.scm \
+ %D%/packages/image-processing.scm \
%D%/packages/image-viewers.scm \
%D%/packages/imagemagick.scm \
%D%/packages/indent.scm \
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
new file mode 100644
index 0000000000..21ee52e7fb
--- /dev/null
+++ b/gnu/packages/image-processing.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 John Darrington <jmd@gnu.org>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages image-processing)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages perl))
+
+;; We use the latest snapshot of this package because the latest release is
+;; from 2011 and has known vulnerabilities that cannot easily be fixed by
+;; applying patches.
+(define-public dcmtk
+ (package
+ (name "dcmtk")
+ (version "3.6.1_20170228")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://dicom.offis.de/pub/dicom/offis/"
+ "software/dcmtk/snapshot/dcmtk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04cwfx8yrscqcd59mxk2fh6314ckayi9cp68iql5a57pf2pg5qld"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("doxygen" ,doxygen)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("perl" ,perl)))
+ (home-page "http://dcmtk.org")
+ (synopsis "Libraries and programs implementing parts of the DICOM standard")
+ (description "DCMTK is a collection of libraries and applications
+implementing large parts the DICOM standard. It includes software for
+examining, constructing and converting DICOM image files, handling offline
+media, sending and receiving images over a network connection, as well as
+demonstrative image storage and worklist servers.")
+ (license (license:fsf-free
+ "file://COPYRIGHT"
+ "A union of the Apache 2.0 licence and various non-copyleft
+licences similar to the Modified BSD licence."))))