summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-08 14:58:07 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-08 20:02:29 -0400
commit9034dc8f2a81d5f645548edfaa43f7698062105b (patch)
tree6be277e2ff515de278e8af1659006f6834cb5fce
parentd14b8dbb748c064e0d43506c17c80cad61665510 (diff)
downloadguix-9034dc8f2a81d5f645548edfaa43f7698062105b.tar.gz
guix-9034dc8f2a81d5f645548edfaa43f7698062105b.tar.xz
gnu: libarchive: Replace with 3.3.1 [security fixes].
Fixes CVE-2016-{10209,10350} and CVE-2017-5601. * gnu/packages/backup.scm (libarchive)[replacement]: New field. (libarchive-3.3.1): New variable.
-rw-r--r--gnu/packages/backup.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index f9c0a22a0d..d5cb5783ab 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -186,6 +187,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
+ (replacement libarchive-3.3.1)
(version "3.2.2")
(source
(origin
@@ -241,6 +243,20 @@ archive. In particular, note that there is currently no built-in support for
random access nor for in-place modification.")
(license license:bsd-2)))
+(define libarchive-3.3.1
+ (package
+ (inherit libarchive)
+ (name "libarchive")
+ (version "3.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://libarchive.org/downloads/libarchive-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rr40hxlm9vy5z2zb5w7pyfkgd1a4s061qapm83s19accb8mpji9"))))))
+
(define-public rdup
(package
(name "rdup")