summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-07 05:29:41 +0300
committerLeo Famulari <leo@famulari.name>2017-05-07 15:22:41 -0400
commitce949c10e50da6b385938c929c257c5ca421d651 (patch)
tree311ca04279ef975539ce6d27a2cbcf775ec0e807
parentfddee154b6358dbcd0f4b3da748f0a5a24ae9bfa (diff)
downloadguix-ce949c10e50da6b385938c929c257c5ca421d651.tar.gz
guix-ce949c10e50da6b385938c929c257c5ca421d651.tar.xz
gnu: Add python-httpbin
* gnu/packages/web.scm (python-httpbin, python2-httpbin): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 19a28553dc..935f80210b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4494,3 +4494,32 @@ functions of Tidy.")
Features include the ability to stop SQL injections, XSS and CSRF attacks and
exploit attempts.")
(license l:gpl2)))
+
+(define-public python-httpbin
+ (package
+ (name "python-httpbin")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpbin" version))
+ (sha256
+ (base32
+ "1dc92lnk846hpilslrqnr63x55cxll4qx88gif8fm521gv9cbyvr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-flask" ,python-flask)
+ ("python-itsdangerous" ,python-itsdangerous)
+ ("python-markupsafe" ,python-markupsafe)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/Runscope/httpbin")
+ (synopsis "HTTP request and response service")
+ (description "Testing an HTTP Library can become difficult sometimes.
+@code{RequestBin} is fantastic for testing POST requests, but doesn't let you control the
+response. This exists to cover all kinds of HTTP scenarios. All endpoint responses are
+JSON-encoded.")
+ (license l:isc)))
+
+(define-public python2-httpbin
+ (package-with-python2 python-httpbin))