summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-04 15:17:23 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-04 16:35:43 +0100
commit3b6e7c703cff14020cfcdaa316875b28282c3477 (patch)
treec9e796e63a32fc1d94a37fa0830b618d77d6aa29
parent2626062b250e0833f2acdf80ef4b8b70c8757673 (diff)
downloadguix-3b6e7c703cff14020cfcdaa316875b28282c3477.tar.gz
guix-3b6e7c703cff14020cfcdaa316875b28282c3477.tar.xz
maint: Add the '.iso' extension to installation images.
* Makefile.am (release): Add the '.iso' suffix to image files. * doc/guix.texi (USB Stick and DVD Installation): Adjust accordingly.
-rw-r--r--Makefile.am6
-rw-r--r--doc/guix.texi16
2 files changed, 11 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 24a803a21a..35d72f36fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -655,9 +655,9 @@ release: dist
echo "failed to produced GuixSD installation image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz.tmp" ; \
- mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz.tmp" \
- "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz" ; \
+ xz < "$$image" > "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" ; \
+ mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" \
+ "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz" ; \
done
for system in $(GUIXSD_VM_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
diff --git a/doc/guix.texi b/doc/guix.texi
index 182dcd82ee..c39e495060 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -7855,7 +7855,7 @@ about their support in GNU/Linux.
An ISO-9660 installation image that can be written to a USB stick or
burnt to a DVD can be downloaded from
-@indicateurl{ftp://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.xz},
+@indicateurl{ftp://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.iso.xz},
where @var{system} is one of:
@table @code
@@ -7871,8 +7871,8 @@ Make sure to download the associated @file{.sig} file and to verify the
authenticity of the image against it, along these lines:
@example
-$ wget ftp://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.xz.sig
-$ gpg --verify guixsd-install-@value{VERSION}.@var{system}.xz.sig
+$ wget ftp://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.iso.xz.sig
+$ gpg --verify guixsd-install-@value{VERSION}.@var{system}.iso.xz.sig
@end example
If that command fails because you do not have the required public key,
@@ -7898,7 +7898,7 @@ To copy the image to a USB stick, follow these steps:
Decompress the image using the @command{xz} command:
@example
-xz -d guixsd-install-@value{VERSION}.@var{system}.xz
+xz -d guixsd-install-@value{VERSION}.@var{system}.iso.xz
@end example
@item
@@ -7907,7 +7907,7 @@ its device name. Assuming that the USB stick is known as @file{/dev/sdX},
copy the image with:
@example
-dd if=guixsd-install-@value{VERSION}.x86_64-linux of=/dev/sdX
+dd if=guixsd-install-@value{VERSION}.x86_64-linux.iso of=/dev/sdX
sync
@end example
@@ -7923,7 +7923,7 @@ To copy the image to a DVD, follow these steps:
Decompress the image using the @command{xz} command:
@example
-xz -d guixsd-install-@value{VERSION}.@var{system}.xz
+xz -d guixsd-install-@value{VERSION}.@var{system}.iso.xz
@end example
@item
@@ -7932,7 +7932,7 @@ its device name. Assuming that the DVD drive is known as @file{/dev/srX},
copy the image with:
@example
-growisofs -dvd-compat -Z /dev/srX=guixsd-install-@value{VERSION}.x86_64
+growisofs -dvd-compat -Z /dev/srX=guixsd-install-@value{VERSION}.x86_64.iso
@end example
Access to @file{/dev/srX} usually requires root privileges.
@@ -8317,7 +8317,7 @@ Boot the USB installation image in an VM:
@example
qemu-system-x86_64 -m 1024 -smp 1 \
-net user -net nic,model=virtio -boot menu=on \
- -drive file=guixsd-install-@value{VERSION}.@var{system} \
+ -drive file=guixsd-install-@value{VERSION}.@var{system}.iso \
-drive file=guixsd.img
@end example