summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-03 11:37:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-03 18:31:47 +0100
commit518957128f8c473fe762c1f41b254d6b7968eea1 (patch)
tree86edbd9e4d8882ce043b4d5150de9bde47c69c4c
parent0a3b5bb3e143e06b2557878f4e6cb4dd74797518 (diff)
downloadguix-518957128f8c473fe762c1f41b254d6b7968eea1.tar.gz
guix-518957128f8c473fe762c1f41b254d6b7968eea1.tar.xz
gnu: Add gst123.
* gnu/packages/gstreamer.scm (gst123): New variable.
-rw-r--r--gnu/packages/gstreamer.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a57676fdf3..3333ca87fd 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages qt)
@@ -469,3 +471,31 @@ be used by Python applications using GStreamer.")
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)
("python-pygobject" ,python2-pygobject)))))
+
+(define-public gst123
+ (package
+ (name "gst123")
+ (version "0.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://space.twc.de/~stefan/gst123/gst123-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0zaa117n4wkya9p903vkj8hj58lmdb66pxsdx5wwcv7nffbp5d67"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("ncurses" ,ncurses)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://space.twc.de/~stefan/gst123.php")
+ (synopsis "Flexible command line media player based on gstreamer")
+ (description "The program gst123 is designed to be a more flexible command
+line player in the spirit of ogg123 and mpg123, based on the gstreamer media
+framework. It plays all file formats gstreamer supports, so if you have a
+music collection which contains different file formats, like flac, ogg and
+mp3, you can use gst123 to play all your music files.")
+ (license license:lgpl2.0+)))