summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-03 19:58:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-04 04:40:15 +0100
commit7e95d0fda7f7f17f9c1431bbe1c3f021b9805328 (patch)
tree8599563172d0593a61de0c1a718235414adfd018
parentf7459997737371c06cdc6b99150ac9684ab343dd (diff)
downloadguix-7e95d0fda7f7f17f9c1431bbe1c3f021b9805328.tar.gz
guix-7e95d0fda7f7f17f9c1431bbe1c3f021b9805328.tar.xz
gnu: ghc-comonad: Remove duplicate input.
* gnu/packages/haskell.scm (ghc-comonad)[inputs]: Remove ghc-contravariant. Order alphabetically to make this less likely to happen again.
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e9a86e25e5..e8c6b25dfd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2370,12 +2370,11 @@ parser isolation, and labeled blocks for better error messages.")
(arguments `(#:tests? #f)) ; FIXME: Test fails with "cannot satisfy
; -package contravariant-1.3.3"
(inputs
- `(("ghc-distributive" ,ghc-distributive)
- ("ghc-transformers-compat" ,ghc-transformers-compat)
- ("ghc-contravariant" ,ghc-contravariant)
+ `(("ghc-contravariant" ,ghc-contravariant)
+ ("ghc-distributive" ,ghc-distributive)
("ghc-semigroups" ,ghc-semigroups)
("ghc-tagged" ,ghc-tagged)
- ("ghc-contravariant" ,ghc-contravariant)))
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
(home-page "https://github.com/ekmett/comonad/")
(synopsis "Comonads for Haskell")
(description "This library provides @code{Comonad}s for Haskell.")