summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-04 15:28:16 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-04 16:35:43 +0100
commitaa1d47e72ee23aa38bbd9d216d68c8ebef351420 (patch)
tree460b9754b85d7df51e988b207a6cb23e14d79d36
parent9d163ec133c55abf4d63b4f6e242d8da731d91eb (diff)
downloadguix-aa1d47e72ee23aa38bbd9d216d68c8ebef351420.tar.gz
guix-aa1d47e72ee23aa38bbd9d216d68c8ebef351420.tar.xz
maint: Let 'guix system vm-image' determine the right size.
* Makefile.am (GUIXSD_VM_IMAGE_BASE): Remove. (release): Remoev --image-size argument to 'guix system vm-image'.
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d340f5720..7cc46d4ac2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -602,9 +602,6 @@ GUIXSD_IMAGE_BASE = guixsd-install-$(PACKAGE_VERSION)
# Prefix of the GuixSD VM image file name.
GUIXSD_VM_IMAGE_BASE = guixsd-vm-image-$(PACKAGE_VERSION)
-# Size of the VM image (for x86_64 typically).
-GUIXSD_VM_IMAGE_SIZE ?= 2GiB
-
# The release process works in several phases:
#
# 0. We assume the developer created a 'vX.Y' tag.
@@ -663,7 +660,6 @@ release: dist
image=`$(top_builddir)/pre-inst-env \
guix system vm-image \
--system=$$system \
- --image-size=$(GUIXSD_VM_IMAGE_SIZE) \
gnu/system/examples/vm-image.tmpl` ; \
if [ ! -f "$$image" ] ; then \
echo "failed to produced GuixSD VM image for $$system" >&2 ; \