summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-04 16:33:59 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-04 16:35:43 +0100
commitc7699ebeb4233d81f294ff7e8b8eb3676119ae4a (patch)
treeb1583e0748d39d0e79d435e17a55aa218b42bfe9
parentaa1d47e72ee23aa38bbd9d216d68c8ebef351420 (diff)
downloadguix-c7699ebeb4233d81f294ff7e8b8eb3676119ae4a.tar.gz
guix-c7699ebeb4233d81f294ff7e8b8eb3676119ae4a.tar.xz
gnu: git: Remove unreliable git-svn tests.
Reported in <https://bugs.gnu.org/29546> by Mark H Weaver <mhw@netris.org>. * gnu/packages/version-control.scm (git)[arguments]: In 'patch-tests' phase, delete three git-svn tests.
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index f7550cb5c8..ba985f6078 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -245,6 +245,13 @@ as well as the classic centralized workflow.")
;; FIXME: Some hooks fail with "basename: command not found".
;; See 't/trash directory.t9164.../svn-hook.log'.
(delete-file "t/t9164-git-svn-dcommit-concurrent.sh")
+
+ ;; XXX: These tests fail intermittently for unknown reasons:
+ ;; <https://bugs.gnu.org/29546>.
+ (for-each delete-file
+ '("t/t9128-git-svn-cmd-branch.sh"
+ "t/t9167-git-svn-cmd-branch-subproject.sh"
+ "t/t9141-git-svn-multiple-branches.sh"))
#t))
(add-after 'install 'install-shell-completion
(lambda* (#:key outputs #:allow-other-keys)