summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-01 10:52:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-03 18:38:58 +0100
commitd112e5a8c2cfc3ff32b143f5a92964e849631ca2 (patch)
treef72198c438cc3c9581b144ae4bf47152282e6490
parent803a9d5c37479c67734c4518a018c8795471ac12 (diff)
downloadguix-d112e5a8c2cfc3ff32b143f5a92964e849631ca2.tar.gz
guix-d112e5a8c2cfc3ff32b143f5a92964e849631ca2.tar.xz
gnu: Add kallisto.
* gnu/packages/bioinformatics.scm (kallisto): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5b3eec86db..f0b589b6c0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11079,3 +11079,32 @@ contains a few programs for model fitting and phylogenetic tree reconstruction
using nucleotide or amino-acid sequence data.")
;; GPLv3 only
(license license:gpl3)))
+
+(define-public kallisto
+ (package
+ (name "kallisto")
+ (version "0.43.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pachterlab/"
+ "kallisto/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03j3iqhvq7ya3c91gidly3k3jvgm97vjq4scihrlxh315j696r11"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no "check" target
+ (inputs
+ `(("hdf5" ,hdf5)
+ ("zlib" ,zlib)))
+ (home-page "http://pachterlab.github.io/kallisto/")
+ (synopsis "Near-optimal RNA-Seq quantification")
+ (description
+ "Kallisto is a program for quantifying abundances of transcripts from
+RNA-Seq data, or more generally of target sequences using high-throughput
+sequencing reads. It is based on the novel idea of pseudoalignment for
+rapidly determining the compatibility of reads with targets, without the need
+for alignment. Pseudoalignment of reads preserves the key information needed
+for quantification, and kallisto is therefore not only fast, but also as
+accurate as existing quantification tools.")
+ (license license:bsd-2)))