summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-05 11:50:00 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-05 11:50:00 +0100
commitf00b85ff8d34df0a1879e593d4a85629b8586af7 (patch)
tree88881d6130c94e454c2dc022836c12168eee2690
parentaab322d909c0b4abec132ef7aff31c31a1208841 (diff)
downloadguix-f00b85ff8d34df0a1879e593d4a85629b8586af7.tar.gz
guix-f00b85ff8d34df0a1879e593d4a85629b8586af7.tar.xz
gnu: commencement: Do not graft early bootstrap packages.
By definition, these packages are not depended on at run time by any of the packages we use. Thus it does not make sense to inherit grafts. Furthermore, those grafts would often lead to extra overhead for users who would end up downloading those "-boot0" packages just to build package replacements that are in fact not going to be used. This reverts parts of f1597427f220b0799b9c8847768d2f5a93fe3730 and ce27857f710ff32c05f4ba19a04a695c1cc2ce20. Reported by Christopher Baines at <https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00058.html>. * gnu/packages/commencement.scm (file-boot0, binutils-boot0): Use plain 'inherit' instead of 'package/inherit'.
-rw-r--r--gnu/packages/commencement.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 406a23b21c..c5c00688e4 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -113,7 +113,8 @@
(define file-boot0
(package-with-bootstrap-guile
- (package-with-explicit-inputs (package/inherit file
+ (package-with-explicit-inputs (package
+ (inherit file)
(name "file-boot0"))
`(("make" ,gnu-make-boot0)
,@%bootstrap-inputs)
@@ -140,7 +141,7 @@
(define binutils-boot0
(package-with-bootstrap-guile
- (package/inherit binutils
+ (package (inherit binutils)
(name "binutils-cross-boot0")
(arguments
`(#:guile ,%bootstrap-guile