summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-07-03 09:33:54 +0200
committerRutger Helling <rhelling@mykolab.com>2018-07-03 11:23:47 +0200
commitcf09bed4f5d2234392a3ab4df409fe1822ded0e6 (patch)
treeb84963886481566977b2bd2afe5e1841d84c9353
parent940c2c5c14745b9559f83fca07db74aaa3f14c5e (diff)
downloadguix-cf09bed4f5d2234392a3ab4df409fe1822ded0e6.tar.gz
guix-cf09bed4f5d2234392a3ab4df409fe1822ded0e6.tar.xz
gnu: Add vulkan-headers.
* gnu/packages/vulkan.scm (vulkan-headers): New variable.
-rw-r--r--gnu/packages/vulkan.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index c83bfdd0c9..f05a6108b6 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -160,6 +160,29 @@ interpretation of the specifications for these languages.")
;; include/SPIRV/{bitutils,hex_float}.h are Apache 2.0.
license:asl2.0)))))
+(define-public vulkan-headers
+ (package
+ (name "vulkan-headers")
+ (version "1.1.77.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/KhronosGroup/Vulkan-Headers/"
+ "archive/sdk-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05pgaqyj516lmzdr4clxll5gvr5zb29sfjhs2d7mkryqs6zk5xdj"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests.
+ (home-page
+ "https://github.com/KhronosGroup/Vulkan-Headers")
+ (synopsis "Vulkan Header files and API registry")
+ (description
+ "Vulkan-Headers contains header files and API registry for Vulkan.")
+ (license (list license:asl2.0)))) ;LICENSE.txt
+
(define-public vulkan-loader
(package
(name "vulkan-loader")