summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-06 12:15:17 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-06 12:16:30 +0200
commit09d5c1661c8c89c1d7b04d7d3f6304a237762f43 (patch)
tree7c8d13b6efe7450b937c28a3ddcf2090b1d6768c
parenta2270ce260373ce0e3dfe1498771906553c1f24e (diff)
downloadguix-09d5c1661c8c89c1d7b04d7d3f6304a237762f43.tar.gz
guix-09d5c1661c8c89c1d7b04d7d3f6304a237762f43.tar.xz
gnu: Add gpgme.
* gnu/packages/gnupg.scm (gpgme): New variable.
-rw-r--r--gnu/packages/gnupg.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 94f1e7ac49..b3b06e4160 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -176,6 +176,37 @@ are available. Version 2 of GnuPG also provides support for
S/MIME.")
(license gpl3+)))
+(define-public gpgme
+ (package
+ (name "gpgme")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnupg/gpgme/gpgme-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "15h429h6pd67iiv580bjmwbkadpxsdppw0xrqpcm4dvm24jc271d"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gnupg" ,gnupg)
+ ("libassuan" ,libassuan)
+ ("libgpg-error" ,libgpg-error)))
+ (home-page "http://www.gnupg.org/related_software/gpgme/")
+ (synopsis "library providing simplified access to GnuPG functionality")
+ (description
+ "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
+easier for applications. It provides a High-Level Crypto API for encryption,
+decryption, signing, signature verification and key management. Currently
+it uses GnuPG as its backend but the API isn't restricted to this engine.
+
+Because the direct use of GnuPG from an application can be a complicated
+programming task, it is suggested that all software should try to use GPGME
+instead. This way bug fixes or improvements can be done at a central place
+and every application benefits from this.")
+ (license lgpl2.1+)))
+
(define-public pius
(package
(name "pius")