summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-08 16:54:06 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-08 17:00:27 -0500
commit0fc54d4b319ede932e5978f672ea095e89711605 (patch)
tree48f66c79ee93eabe4ac73cdafc3a332017bb62ee
parent2cf287df596fb3490f0313c324b5c70ee5cb3aa7 (diff)
downloadguix-0fc54d4b319ede932e5978f672ea095e89711605.tar.gz
guix-0fc54d4b319ede932e5978f672ea095e89711605.tar.xz
gnu: fftw: Add dependency on openmpi.
* gnu/packages/algebra.scm (fftw)[inputs,arguments]: Add OpenMPI.
-rw-r--r--gnu/packages/algebra.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index b7e067af00..7d2d50cc75 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages algebra)
#:use-module (gnu packages)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages mpi)
#:use-module (gnu packages perl)
#:use-module (gnu packages readline)
#:use-module (gnu packages flex)
@@ -206,7 +207,7 @@ syntax is similar to that of C, so basic usage is familiar. It also includes
"10h9mzjxnwlsjziah4lri85scc05rlajz39nqf3mbh4vja8dw34g"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--enable-shared" "--enable-openmp")
+ '(#:configure-flags '("--enable-shared" "--enable-openmp" "--enable-mpi")
#:phases (alist-cons-before
'build 'no-native
(lambda _
@@ -218,6 +219,7 @@ syntax is similar to that of C, so basic usage is familiar. It also includes
(("-mtune=native") "")))
%standard-phases)))
(native-inputs `(("perl" ,perl)))
+ (inputs `(("openmpi" ,openmpi)))
(home-page "http://fftw.org")
(synopsis "Computing the discrete Fourier transform")
(description