summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-23 16:08:09 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-28 16:09:57 +0100
commit18a5a9a17ad05d5f4fe8ea794a3cec2550a61c11 (patch)
treef4ee3818c75e123d2db285a2712c2176c0bec6fb
parent88c6b58020c362b47aa907380a5948c8fb31cd0c (diff)
downloadguix-18a5a9a17ad05d5f4fe8ea794a3cec2550a61c11.tar.gz
guix-18a5a9a17ad05d5f4fe8ea794a3cec2550a61c11.tar.xz
gnu: Add libupnp.
* gnu/packages/libupnp.scm: New file. * gnu-system.am: Add the new file.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/libupnp.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 95a00438b7..f09b5bd5c0 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -163,6 +163,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/libunistring.scm \
gnu/packages/libusb.scm \
gnu/packages/libunwind.scm \
+ gnu/packages/libupnp.scm \
gnu/packages/lightning.scm \
gnu/packages/links.scm \
gnu/packages/linux.scm \
diff --git a/gnu/packages/libupnp.scm b/gnu/packages/libupnp.scm
new file mode 100644
index 0000000000..520bf1c297
--- /dev/null
+++ b/gnu/packages/libupnp.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libupnp)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libupnp
+ (package
+ (name "libupnp")
+ (version "1.6.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
+ version "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0amjv4lypvclmi4vim2qdyw5xa6v4x50zjgf682vahqjc0wjn55k"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The tests require a network device capable of multicasting which is
+ ;; not available in the build environment. See
+ ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
+ `(#:tests? #f
+ #:configure-flags '("--enable-ipv6")))
+ (home-page "http://pupnp.sourceforge.net")
+ (synopsis "Portable SDK for UPnP Devices")
+ (description
+ "The portable SDK for UPnP Devices (libupnp) provides developers with an
+API and open source code for building control points, devices, and bridges
+that are compliant with Version 1.0 of the Universal Plug and Play Device
+Architecture Specification and support several operating systems like Linux,
+*BSD, Solaris and others.")
+ (license bsd-3)))