summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-28 14:23:14 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-28 14:23:14 +0100
commit2fd22ec52c75d9ac8875891d9242f7a8d422716a (patch)
treeff43243bcb642de6b04702c62d29a80f8563b256
parent2c6361958864df8b17dd2ecfbac42c9b0e74557e (diff)
downloadguix-2fd22ec52c75d9ac8875891d9242f7a8d422716a.tar.gz
guix-2fd22ec52c75d9ac8875891d9242f7a8d422716a.tar.xz
gnu: libextractor: Adjust to deal with current libmagic.
* gnu/packages/gnunet.scm (libextractor)[source]: Add 'snippet'. (libextractor)[inputs]: Remove GNU-GETTEXT, which was unneeded. Add FILE.
-rw-r--r--gnu/packages/gnunet.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 96b517b9a9..4158c05112 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages gnunet)
#:use-module (gnu packages)
+ #:use-module (gnu packages file)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -56,7 +58,14 @@
version ".tar.gz"))
(sha256
(base32
- "0zvv7wd011npcx7yphw9bpgivyxz6mlp87a57n96nv85k96dd2l6"))))
+ "0zvv7wd011npcx7yphw9bpgivyxz6mlp87a57n96nv85k96dd2l6"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Nowadays libmagic (from 'file') returns 'audio/ogg' and not
+ ;; 'application/ogg'. Adjust accordingly.
+ '(substitute* "src/plugins/test_mime.c"
+ (("application/ogg")
+ "audio/ogg")))))
(build-system gnu-build-system)
;; WARNING: Checks require /dev/shm to be in the build chroot, especially
;; not to be a symbolic link to /run/shm.
@@ -78,7 +87,7 @@
`(("exiv2" ,exiv2)
("flac" ,flac)
("ffmpeg" ,ffmpeg)
- ("gettext" ,gnu-gettext)
+ ("file" ,file) ;libmagic, for the MIME plug-in
("glib" ,glib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)