summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-13 16:25:29 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-18 18:05:52 +0100
commit31aa437987e325808b7ed308601c4615c395e3f8 (patch)
treeac521cde4ce69ca7dfeca11600572275a3bf7744
parentb6e5e1b738d39792ed597bf6d04603a63b85aee2 (diff)
downloadguix-31aa437987e325808b7ed308601c4615c395e3f8.tar.gz
guix-31aa437987e325808b7ed308601c4615c395e3f8.tar.xz
gnu: eudev: Add pre-build phase.
* gnu/packages/linux.scm (eudev): Add 'pre-build phase to fix compilation with 'gobject-introspection' 1.42.0.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 952b9d1dc5..d48a8e9633 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1474,7 +1475,18 @@ from the module-init-tools project.")
;; Work around undefined reference to
;; 'mq_getattr' in sc-daemon.c.
- "LDFLAGS=-lrt")))
+ "LDFLAGS=-lrt")
+ #:phases
+ (alist-cons-before
+ 'build 'pre-build
+ ;; The program 'g-ir-scanner' (part of the package
+ ;; 'gobject-introspection'), to generate .gir files, makes some
+ ;; library pre-processing. During that phase it looks for the C
+ ;; compiler as either 'cc' or as defined by the environment variable
+ ;; 'CC' (with code in 'giscanner/dumper.py').
+ (lambda* _
+ (setenv "CC" "gcc"))
+ %standard-phases)))
(home-page "http://www.gentoo.org/proj/en/eudev/")
(synopsis "Userspace device management")
(description "Udev is a daemon which dynamically creates and removes