summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-14 17:02:02 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-18 18:05:53 +0100
commit3e6ccb53559c8a0cb9ea010ec747df4e5972fcd3 (patch)
treeb221ea04a4f14137bf1159419bd1dbee4ba13154
parenta6035fc19aecabca8ca9d38f4194efc170837758 (diff)
downloadguix-3e6ccb53559c8a0cb9ea010ec747df4e5972fcd3.tar.gz
guix-3e6ccb53559c8a0cb9ea010ec747df4e5972fcd3.tar.xz
gnu: python-matplotlib: Update comments.
* gnu/packages/python.scm (python-matplotlib): Update comments as, with the patched 'gobject-introspection', setting LD_LIBRARY_PATH at run time is not anymore necessary. It's still necessary at build time.
-rw-r--r--gnu/packages/python.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7cfbf75290..a1be20c21f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2170,13 +2170,6 @@ that client code uses to construct the grammar directly in Python code.")
;; at run-time the user must set this variable as follows:
;;
;; export GI_TYPELIB_PATH=~/.guix-profile/lib/girepository-1.0
- ;;
- ;; 'typelib' files include references to dynamic libraries. Currently
- ;; the references do not include the full path to the libraries. For
- ;; this reason the user must set the LD_LIBRARY_PATH to the location of
- ;; 'libgtk-3.so.0', 'libgdk-3.so.0' and 'libatk-1.0.so.0':
- ;;
- ;; export LD_LIBRARY_PATH=~/.guix-profile/lib
("gtk+" ,gtk+)
;; From version 1.4.0 'matplotlib' makes use of 'cairocffi' instead of
;; 'pycairo'. However, 'pygobject' makes use of a 'pycairo' 'context'
@@ -2217,10 +2210,6 @@ that client code uses to construct the grammar directly in Python code.")
(gtk+ (assoc-ref inputs "gtk+")))
;; Setting these directories in the 'basedirlist' of 'setup.cfg'
;; has not effect.
- ;;
- ;; FIXME: setting LD_LIBRARY_PATH should be removed once we patch
- ;; gobject-introspection to include the full path of shared
- ;; libraries in 'typelib' files.
(setenv "LD_LIBRARY_PATH"
(string-append cairo "/lib:" gtk+ "/lib"))
(setenv "HOME" (getcwd))