summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-20 18:43:55 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-21 13:44:47 +0100
commit58d32305b609eccf54de620398a54457af0af0c5 (patch)
tree4c38fde7c3f39efd73b4c8faf043e37c352cb248
parent7ed6ee1e34011189b42c32d305ac2c2f6b9efa17 (diff)
downloadguix-58d32305b609eccf54de620398a54457af0af0c5.tar.gz
guix-58d32305b609eccf54de620398a54457af0af0c5.tar.xz
gnu: libpeas: Update to 1.12.1, add 'pre-build phase.
* gnu/packages/gnome.scm (libpeas): Update to version 1.12.1 and add 'pre-build phase.
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index acc964e7fc..0f33880a21 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -427,7 +428,7 @@ some form of information without getting in the user's way.")
(define-public libpeas
(package
(name "libpeas")
- (version "1.9.0")
+ (version "1.12.1")
(source
(origin
(method url-fetch)
@@ -436,7 +437,7 @@ some form of information without getting in the user's way.")
name "-" version ".tar.xz"))
(sha256
(base32
- "13fzyzv6c0cfdj83z1s16lv8k997wpnzyzr0wfwcfkcmvz64g1q0"))))
+ "1mjjjjwphc83bjznmbsm7x0jg7ql261nys6qnl7mi0nkr4qvw476"))))
(build-system gnu-build-system)
(inputs
`(("atk" ,atk)
@@ -449,6 +450,13 @@ some form of information without getting in the user's way.")
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)))
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'build 'pre-build
+ (lambda* _
+ (setenv "CC" "gcc"))
+ %standard-phases)))
(home-page "https://wiki.gnome.org/Libpeas")
(synopsis "GObject plugin system")
(description
@@ -457,7 +465,6 @@ every application the chance to assume its own extensibility. It also has a
set of features including, but not limited to: multiple extension points; on
demand (lazy) programming language support for C, Python and JS; simplicity of
the API")
-
(license license:lgpl2.0+)))
(define-public gtkglext