summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-01-25 21:09:39 +0300
committerAlex Kost <alezost@gmail.com>2015-01-27 18:02:45 +0300
commit6256553cc14bc4cf27e0761bae13051597832900 (patch)
tree4f1dc035d6811d0d2ce439531333dccf653337ef
parent74574fd1e3fad5e0c1d061ce194e47dde0f7f175 (diff)
downloadguix-6256553cc14bc4cf27e0761bae13051597832900.tar.gz
guix-6256553cc14bc4cf27e0761bae13051597832900.tar.xz
gnu: Add sxiv.
* gnu/packages/sxiv.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/sxiv.scm61
2 files changed, 62 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 9d2f6b5cf9..95a00438b7 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -252,6 +252,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/ssh.scm \
gnu/packages/stalonetray.scm \
gnu/packages/swig.scm \
+ gnu/packages/sxiv.scm \
gnu/packages/synergy.scm \
gnu/packages/tcl.scm \
gnu/packages/tcsh.scm \
diff --git a/gnu/packages/sxiv.scm b/gnu/packages/sxiv.scm
new file mode 100644
index 0000000000..4c068e5366
--- /dev/null
+++ b/gnu/packages/sxiv.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sxiv)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages photo))
+
+(define-public sxiv
+ (package
+ (name "sxiv")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/muennich/sxiv/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03hxy5ff7xbs15rhlbpgx8xmvmpjlffp0m4528975hg16sqa2c4s"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags (list (string-append "PREFIX=" %output)
+ "CC=gcc")
+ #:phases (alist-delete
+ 'configure ; no configure phase
+ %standard-phases)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("imlib2" ,imlib2)
+ ("giflib" ,giflib)
+ ("libexif" ,libexif)))
+ (home-page "https://github.com/muennich/sxiv")
+ (synopsis "Simple X Image Viewer")
+ (description
+ "sxiv is an alternative to feh and qiv. Its primary goal is to
+provide the most basic features required for fast image viewing. It has
+vi key bindings and works nicely with tiling window managers. Its code
+base should be kept small and clean to make it easy for you to dig into
+it and customize it for your needs.")
+ (license license:gpl2+)))