summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-27 21:27:52 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-27 21:32:07 +0100
commit6bc64f418740e176011498aca2abf4d4ff43d2c6 (patch)
treefcb36ce63dcecbf7d12247a96dd21637378047dd
parent3a5d914b5ec9d75a6cb54c25ca112f827408346b (diff)
downloadguix-6bc64f418740e176011498aca2abf4d4ff43d2c6.tar.gz
guix-6bc64f418740e176011498aca2abf4d4ff43d2c6.tar.xz
gnu: Add xinit.
* gnu/packages/xorg.scm (xinit): New variable.
-rw-r--r--gnu/packages/xorg.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b636918139..72a86aa85d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4772,6 +4772,33 @@ ewmh: Both client and window-manager helpers for EWMH.
icccm: Both client and window-manager helpers for ICCCM.")
(license license:x11)))
+(define-public xinit
+ (package
+ (name "xinit")
+ (version "1.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/app/xinit-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1cq2g469mb2cfgr8k57960yrn90bl33vfqri4pdh2zm0jxrqvn3m"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("xproto" ,xproto)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("xauth" ,xauth)))
+ (home-page "http://x.org")
+ (synopsis "Commands to start the X Window server")
+ (description
+ "The xinit program is used to start the X Window System server and a
+first client program on systems that are not using a display manager such as
+xdm. This package also provides the 'startx' command, which provides a
+user-friendly mechanism to start the X server.")
+ (license license:x11)))
;; package outside the x.org system proper of height 5