summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-01-19 18:04:12 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-19 18:04:12 +0100
commit7ed6ee1e34011189b42c32d305ac2c2f6b9efa17 (patch)
treec89d83963eb5e200ed6a4d7c03f9279047d69d10
parent0404c34cb7b4d7704dbaf569a855f3e59ee7d331 (diff)
downloadguix-7ed6ee1e34011189b42c32d305ac2c2f6b9efa17.tar.gz
guix-7ed6ee1e34011189b42c32d305ac2c2f6b9efa17.tar.xz
gnu: vte: Add 'pre-build phase.
* gnu/packages/gnome.scm (vte): Add 'pre-build phase.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 20f4078400..acc964e7fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1344,6 +1344,13 @@ libraries written in C.")
("xmllint" ,libxml2)))
(propagated-inputs
`(("gtk+" ,gtk+))) ; required by libvte-2.91.pc
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'build 'pre-build
+ (lambda* _
+ (setenv "CC" "gcc"))
+ %standard-phases)))
(home-page "http://www.gnome.org/")
(synopsis "Virtual Terminal Emulator")
(description