summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-28 15:23:40 -0500
committerMark H Weaver <mhw@netris.org>2015-01-28 15:26:31 -0500
commit9dcd1b3b1c81aa71cf954fa5fca1c15cd3225885 (patch)
treeddf88b9999b76a6266a3ec2a3fc3ce8b52b73803
parent18a5a9a17ad05d5f4fe8ea794a3cec2550a61c11 (diff)
downloadguix-9dcd1b3b1c81aa71cf954fa5fca1c15cd3225885.tar.gz
guix-9dcd1b3b1c81aa71cf954fa5fca1c15cd3225885.tar.xz
gnu: guile-ssh: Put 'autoreconf' phase after 'unpack', not before 'configure'.
* gnu/packages/ssh.scm (guile-ssh): Add 'autoreconf' phase after 'unpack' instead of before 'configure', so that it will be before 'patch-usr-bin-file' and other similar phases.
-rw-r--r--gnu/packages/ssh.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 79e8077cdf..7cdc305e9f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -197,8 +197,8 @@ Additionally, various channel-specific options can be negotiated.")
"1sbxhmynmpwfjwb3dp6lrc3cxi5kffqmb6klhx7wnkgqxvs61lsw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'autoreconf
+ '(#:phases (alist-cons-after
+ 'unpack 'autoreconf
(lambda* (#:key inputs #:allow-other-keys)
(chmod "doc/version.texi" #o777) ;make it writable
(zero? (system* "autoreconf" "-vfi")))