summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-23 14:23:54 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-23 16:29:20 +0100
commitc44ed26ce78e27b625f5c53d58037db63822f5e4 (patch)
tree378e64318869473518ecd819454ef23a7b54edce
parent9f533d60df8c248c790c41d80653e693e1a3f9e5 (diff)
downloadguix-c44ed26ce78e27b625f5c53d58037db63822f5e4.tar.gz
guix-c44ed26ce78e27b625f5c53d58037db63822f5e4.tar.xz
gnu: e2fsprogs: Don't build libraries and commands provided by util-linux.
* gnu/packages/linux.scm (e2fsprogs)[arguments]: Add --disable-blkid --disable-libuuid --disable-uuidd --disable-fsck.
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3e18441812..8b73190d90 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -528,10 +528,12 @@ slabtop, and skill.")
(native-inputs `(("pkg-config" ,pkg-config)
("texinfo" ,texinfo))) ;for the libext2fs Info manual
(arguments
- '(;; The 'blkid' command and library are already provided by util-linux,
- ;; which is the preferred source for them (see, e.g.,
+ '(;; util-linux is not the preferred source for some of the libraries and
+ ;; commands, so disable them (see, e.g.,
;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b336339909c90559b7db40b455f172>.)
- #:configure-flags '("--disable-blkid"
+ #:configure-flags '("--disable-libblkid"
+ "--disable-libuuid" "--disable-uuidd"
+ "--disable-fsck"
;; Install libext2fs et al.
"--enable-elf-shlibs")