summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-05 16:47:12 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-05 16:47:12 +0200
commitc762e82e5d9b6856da46d5999d0137ec3e374af3 (patch)
tree8433b1953d2b5bb9b1e67d53a11bd22c14133085
parente0029b745aee7b4f2a4bb86394a154929a8fbc7a (diff)
downloadguix-c762e82e5d9b6856da46d5999d0137ec3e374af3.tar.gz
guix-c762e82e5d9b6856da46d5999d0137ec3e374af3.tar.xz
gnu: Add libcap.
* gnu/packages/linux.scm (libcap): New variable.
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9d0b93d406..1f9405fee2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages algebra)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'g:))
+ #:use-module (gnu packages attr)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -638,3 +639,37 @@ netstat, rarp and route. Additionally, this package contains utilities
relating to particular network hardware types (plipconfig, slattach) and
advanced aspects of IP configuration (iptunnel, ipmaddr).")
(license gpl2+)))
+
+(define-public libcap
+ (package
+ (name "libcap")
+ (version "2.22")
+ (source (origin
+ (method url-fetch)
+
+ ;; Tarballs used to be available from
+ ;; <https://www.kernel.org/pub/linux/libs/security/linux-privs/>
+ ;; but they never came back after kernel.org was compromised.
+ (uri (string-append
+ "mirror://debian/pool/main/libc/libcap2/libcap2_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "07vjhkznm82p8dm4w6j8mmg7h5c70lp5s9bwwfdmgwpbixfydjp1"))))
+ (build-system gnu-build-system)
+ (arguments '(#:phases (alist-delete 'configure %standard-phases)
+ #:tests? #f ; no 'check' target
+ #:make-flags (list "lib=lib"
+ (string-append "prefix="
+ (assoc-ref %outputs "out"))
+ "RAISE_SETFCAP=no")))
+ (native-inputs `(("perl" ,perl)))
+ (inputs `(("attr" ,attr)))
+ (home-page "https://sites.google.com/site/fullycapable/")
+ (synopsis "Library for working with POSIX capabilities")
+ (description
+ "libcap2 provides a programming interface to POSIX capabilities on
+Linux-based operating systems.")
+
+ ;; License is BSD-3 or GPLv2, at the user's choice.
+ (license gpl2)))