summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-04 00:17:07 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-04 00:17:07 +0200
commitf5bf403c722c1fde1e7b7bedddaed48390a47286 (patch)
treeeec5df29e8bb881ca5204560277183735798f478
parentdfba405510e4f81d1e05ac647afdd28ca04c8a56 (diff)
downloadguix-f5bf403c722c1fde1e7b7bedddaed48390a47286.tar.gz
guix-f5bf403c722c1fde1e7b7bedddaed48390a47286.tar.xz
gnu: xorg: Add xcb-util-keysyms.
* gnu/packages/xorg.scm (xcb-util-keysyms): New variable.
-rw-r--r--gnu/packages/xorg.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 5bb0a97528..348fb25581 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4526,6 +4526,36 @@ image: Port of Xlib's XImage and XShmImage functions.")
(license license:x11)))
+(define-public xcb-util-keysyms
+ (package
+ (name "xcb-util-keysyms")
+ (version "0.3.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://xcb.freedesktop.org/dist/" name "-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0vjwk7vrcfnlhiadv445c6skfxmdrg5v4qf81y8s2s5xagqarqbv"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("libxcb" ,libxcb)))
+ (inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://cgit.freedesktop.org/xcb/util-keysyms/")
+ (synopsis "Standard X constants and conversion to/from keycodes")
+ (description "The XCB util module provides a number of libraries which
+ sit on top of libxcb, the core X protocol library, and some of the
+ extension libraries. These experimental libraries provide convenience
+functions and interfaces which make the raw X protocol more usable. Some of
+the libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-keysyms module provides the following library:
+keysyms: Standard X key constants and conversion to/from keycodes.")
+ (license license:x11)))
+
+
(define-public xcb-util-wm
(package
(name "xcb-util-wm")