summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-11 22:37:21 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-11 22:54:27 +0200
commit1c625dd3726ecec879a3628ec3e4c89bde00a8c6 (patch)
tree2e3a1054d070c5ec55c25822e6b6236cd0861d20
parent2a9a94419a35702958b3933eddf1df59c10aac40 (diff)
downloadguix-1c625dd3726ecec879a3628ec3e4c89bde00a8c6.tar.gz
guix-1c625dd3726ecec879a3628ec3e4c89bde00a8c6.tar.xz
gnu: Add hyphen.
* gnu/packages/libreoffice.scm (hyphen): New variable.
-rw-r--r--gnu/packages/libreoffice.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 0a88e03875..6f7bda3b31 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -529,3 +529,24 @@ library and program designed for languages with rich morphology and complex
word compounding or character encoding.")
;; triple license, including "mpl1.1 or later"
(license (list mpl1.1 gpl2+ lgpl2.1+))))
+
+(define-public hyphen
+ (package
+ (name "hyphen")
+ (version "2.8.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/hunspell/"
+ name "-" version ".tar.gz"))
+ (sha256 (base32
+ "01ap9pr6zzzbp4ky0vy7i1983fwyqy27pl0ld55s30fdxka3ciih"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "http://hunspell.sourceforge.net/")
+ (synopsis "Hyphenation library")
+ (description "Hyphen is a hyphenation library using TeX hyphenation
+patterns, which are pre-processed by a perl script.")
+ ;; triple license, including "mpl1.1 or later"
+ (license (list mpl1.1 mpl2.0 gpl2+ lgpl2.1+))))