summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-05-12 15:29:06 +0200
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-05-13 01:09:18 +0200
commit1e61e22f4d5e1f82389fe62246e69b661806b4c4 (patch)
tree052fd3d31eb23b0abc5167e4217d763696844975
parent9e2292ef3d9e2626381f9726c72d71057160b7c3 (diff)
downloadguix-1e61e22f4d5e1f82389fe62246e69b661806b4c4.tar.gz
guix-1e61e22f4d5e1f82389fe62246e69b661806b4c4.tar.xz
gnu: Add miredo.
* gnu/packages/networking.scm (miredo): New variable.
-rw-r--r--gnu/packages/networking.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b9125af509..dd13e1720b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -24,7 +24,35 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages openssl))
-;; XXX: Group with other networking tools like tcpdump in a module?
+(define-public miredo
+ (package
+ (name "miredo")
+ (version "1.2.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.remlab.net/files/miredo/miredo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0j9ilig570snbmj48230hf7ms8kvcwi2wblycqrmhh85lksd49ps"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; The checkconf test in src/ requires network access.
+ (add-before
+ 'check 'disable-checkconf-test
+ (lambda _
+ (substitute* "src/Makefile"
+ (("^TESTS = .*") "TESTS = \n")))))))
+ (home-page "http://www.remlab.net/miredo/")
+ (synopsis "Teredo IPv6 tunneling software")
+ (description
+ "Miredo is an implementation (client, relay, server) of the Teredo
+specification, which provides IPv6 Internet connectivity to IPv6 enabled hosts
+residing in IPv4-only networks, even when they are behind a NAT device.")
+ (license license:gpl2+)))
+
(define-public socat
(package
(name "socat")