summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-11 22:53:47 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-11 22:54:27 +0200
commit2320ea1a51ce707ca19967f50e6fbedefafe14c4 (patch)
tree546e71ee0eff313dde479759a82a0d5251ba829e
parent1c625dd3726ecec879a3628ec3e4c89bde00a8c6 (diff)
downloadguix-2320ea1a51ce707ca19967f50e6fbedefafe14c4.tar.gz
guix-2320ea1a51ce707ca19967f50e6fbedefafe14c4.tar.xz
gnu: Add MyThes.
* gnu/packages/libreoffice.scm (mythes): New variable.
-rw-r--r--gnu/packages/libreoffice.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 6f7bda3b31..539600a12b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -550,3 +550,28 @@ word compounding or character encoding.")
patterns, which are pre-processed by a perl script.")
;; triple license, including "mpl1.1 or later"
(license (list mpl1.1 mpl2.0 gpl2+ lgpl2.1+))))
+
+(define-public mythes
+ (package
+ (name "mythes")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/hunspell/"
+ name "-" version ".tar.gz"))
+ (sha256 (base32
+ "0prh19wy1c74kmzkkavm9qslk99gz8h8wmjvwzjc6lf8v2az708y"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("hunspell" ,hunspell)
+ ("perl" ,perl)))
+ (home-page "http://hunspell.sourceforge.net/")
+ (synopsis "Thesaurus")
+ (description "MyThes is a simple thesaurus that uses a structured text
+data file and an index file with binary search to look up words and phrases
+and to return information on pronunciations, meaningss and synonyms.")
+ (license (non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))