summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 23:16:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit36ffaca2469e6a98e23f59c4a7e82ed985710310 (patch)
treeedcc607f08d79f9aafce3917a21b0de303f2aa4b
parentc217cbd84d7aee7414945a6cf85e1d704fff6e32 (diff)
downloadguix-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar.gz
guix-36ffaca2469e6a98e23f59c4a7e82ed985710310.tar.xz
doc: Add desktop configuration example.
* gnu/system/examples/bare-bones.tmpl: Change 'packages' and 'host-name'. Remove D-Bus, Avahi, and SLiM services, and add lsh instead. * gnu/system/examples/desktop.tmpl: New file. * Makefile.am (EXAMPLES): Add it.
-rw-r--r--Makefile.am3
-rw-r--r--gnu/system/examples/bare-bones.tmpl23
-rw-r--r--gnu/system/examples/desktop.tmpl42
3 files changed, 55 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index b20421a753..6478aeb8e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,7 +135,8 @@ KCONFIGS = \
# Templates, examples.
EXAMPLES = \
- gnu/system/examples/bare-bones.tmpl
+ gnu/system/examples/bare-bones.tmpl \
+ gnu/system/examples/desktop.tmpl
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go guix/tests.go
diff --git a/gnu/system/examples/bare-bones.tmpl b/gnu/system/examples/bare-bones.tmpl
index e14c95733a..8f4faca2d3 100644
--- a/gnu/system/examples/bare-bones.tmpl
+++ b/gnu/system/examples/bare-bones.tmpl
@@ -1,12 +1,13 @@
-;; This is an operating system configuration template.
+;; This is an operating system configuration template
+;; for a "bare bones" setup, with no X11 display server.
(use-modules (gnu))
-(use-service-modules xorg networking dbus avahi)
-(use-package-modules xorg avahi)
+(use-service-modules networking ssh)
+(use-package-modules admin)
(operating-system
- (host-name "antelope")
- (timezone "Europe/Paris")
+ (host-name "komputilo")
+ (timezone "Europe/Berlin")
(locale "en_US.UTF-8")
;; Assuming /dev/sdX is the target hard disk, and "root" is
@@ -36,12 +37,10 @@
(home-directory "/home/alice"))))
;; Globally-installed packages.
- (packages (cons xterm %base-packages))
+ (packages (cons tcpdump %base-packages))
- ;; Add services to the baseline: the SLiM log-in manager
- ;; for Xorg sessions, a DHCP client, Avahi, and D-Bus.
- (services (cons* (slim-service)
- (dhcp-client-service)
- (avahi-service)
- (dbus-service (list avahi))
+ ;; Add services to the baseline: a DHCP client and
+ ;; an SSH server.
+ (services (cons* (dhcp-client-service)
+ (lsh-service #:port-number 2222)
%base-services)))
diff --git a/gnu/system/examples/desktop.tmpl b/gnu/system/examples/desktop.tmpl
new file mode 100644
index 0000000000..07e3f0b1d6
--- /dev/null
+++ b/gnu/system/examples/desktop.tmpl
@@ -0,0 +1,42 @@
+;; This is an operating system configuration template
+;; for a "desktop" setup with X11.
+
+(use-modules (gnu) (gnu system nss))
+(use-service-modules desktop)
+(use-package-modules xfce ratpoison wicd avahi xorg)
+
+(operating-system
+ (host-name "antelope")
+ (timezone "Europe/Paris")
+ (locale "en_US.UTF-8")
+
+ ;; Assuming /dev/sdX is the target hard disk, and "root" is
+ ;; the label of the target root file system.
+ (bootloader (grub-configuration (device "/dev/sdX")))
+ (file-systems (cons (file-system
+ (device "root")
+ (title 'label)
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+
+ (users (list (user-account
+ (name "bob")
+ (comment "Alice's brother")
+ (group "users")
+ (supplementary-groups '("wheel"
+ "audio" "video"))
+ (home-directory "/home/bob"))))
+
+ ;; Add Xfce and Ratpoison; that allows us to choose
+ ;; sessions using either of these at the log-in screen.
+ (packages (cons* xfce ratpoison ;desktop environments
+ xterm wicd avahi ;useful tools
+ %base-packages))
+
+ ;; Use the "desktop" services, which include the X11
+ ;; log-in service, networking with Wicd, and more.
+ (services %desktop-services)
+
+ ;; Allow resolution of '.local' host names with mDNS.
+ (name-service-switch %mdns-host-lookup-nss))