summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-07 04:51:26 -0400
committerMark H Weaver <mhw@netris.org>2015-05-07 05:06:26 -0400
commit46138f3e226c983452766bf237a0aa86af4184f5 (patch)
tree71dcba189787f497931223b068db16bf8499bb55
parented86593620cad3f069581585cb9e763423d18294 (diff)
downloadguix-46138f3e226c983452766bf237a0aa86af4184f5.tar.gz
guix-46138f3e226c983452766bf237a0aa86af4184f5.tar.xz
gnu: subversion: Add serf to inputs.
This is a followup to d5e9f3809dc7d521874cfad0a242ab664f6c19bc, which upgraded subversion to 1.8.x. Previously we used 'neon' to support http access methods, but subversion 1.8 drops support for 'neon' in favor of 'serf'. * gnu/packages/version-control.scm (subversion)[inputs]: Add 'serf' and remove 'neon'. [arguments]: Fix typo in phase name.
-rw-r--r--gnu/packages/version-control.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index fbe2c74a17..d21139248b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openssl)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages web)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -574,7 +575,7 @@ property manipulation.")
(substitute* "libtool"
(("\\\\`ls") (string-append "\\`" coreutils "/bin/ls")))))
(alist-cons-after
- 'install 'instal-perl-bindings
+ 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from
;; 'subversion/bindings/swig/INSTALL'.
@@ -603,7 +604,7 @@ property manipulation.")
(inputs
`(("apr" ,apr)
("apr-util" ,apr-util)
- ("neon" ,neon-0.29.6)
+ ("serf" ,serf)
("perl" ,perl)
("python" ,python-2) ; incompatible with Python 3 (print syntax)
("sqlite" ,sqlite)