summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-07 00:53:48 -0400
committerMark H Weaver <mhw@netris.org>2015-05-07 00:54:17 -0400
commitdd4a86207ef7be22faa825cc828dff3f82aabf2e (patch)
treee19df3f97ebdf5311768e3eec27f016303bb3e3c
parent9e006fb3de0bd1af2434b32c3be23101e00b1b10 (diff)
downloadguix-dd4a86207ef7be22faa825cc828dff3f82aabf2e.tar.gz
guix-dd4a86207ef7be22faa825cc828dff3f82aabf2e.tar.xz
gnu: Add dosfstools.
* gnu/packages/disk.scm (dosfstools): New variable.
-rw-r--r--gnu/packages/disk.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 6a7fdcfb19..22fdd290a0 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,3 +120,30 @@ from one file to another, working to rescue data in case of read errors. The
program also includes a tool for manipulating its log files, which are used
to recover data more efficiently by only reading the necessary blocks.")
(license gpl3+)))
+
+(define-public dosfstools
+ (package
+ (name "dosfstools")
+ (version "3.0.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/" name "/" name
+ "/releases/download/v" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1a2qs5g2zqbk1gzaaf4v3fw3yny6jgbzddpgcamkp3fjifn8wxl5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ "CC=gcc")
+ #:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/dosfstools/dosfstools")
+ (synopsis "Utilities for making and checking MS-DOS FAT filesystems")
+ (description
+ "The dosfstools package includes the mkfs.fat and fsck.fat utilities,
+which respectively make and check MS-DOS FAT filesystems.")
+ (license gpl3+)))