summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-07-16 16:39:45 -0500
committerEric Bavier <bavier@member.fsf.org>2015-07-16 16:47:05 -0500
commit355e53c4ca95b309b74a815559a960e0624b034f (patch)
tree17c770df3a60e40c11f090609568e93ae89f53b2
parente4d801623e7a64b3de8aadd00b5e4a1aa34728a7 (diff)
downloadguix-355e53c4ca95b309b74a815559a960e0624b034f.tar.gz
guix-355e53c4ca95b309b74a815559a960e0624b034f.tar.xz
gnu: git: Adjust to new handling of propagated inputs.
This is a followup to 161094c, which gets rid of the "a/b" notation for propagated inputs. * gnu/packages/version-control.scm (package-transitive-propagated-labels*): Do not prepend the package name to its input label. (package-propagated-input-refs): Delete duplicate labels. (git)[arguments]: Adjust wrapping of git-send-email accordingly.
-rw-r--r--gnu/packages/version-control.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index e3498ee76f..d89ce09dab 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -104,7 +104,7 @@ as well as the classic centralized workflow.")
`(,name
,@(map (match-lambda
((label (? package? _) . _)
- (string-append name "/" label)))
+ label))
(package-transitive-propagated-inputs package)))))
(define (package-propagated-input-refs inputs packages)
@@ -112,8 +112,9 @@ as well as the classic centralized workflow.")
PACKAGES and their propagated inputs."
(map (lambda (l)
`(assoc-ref ,inputs ,l))
- (append-map package-transitive-propagated-labels*
- packages)))
+ (delete-duplicates ;XXX: efficiency
+ (append-map package-transitive-propagated-labels*
+ packages))))
(define-public git
;; Keep in sync with 'git-manpages'!
@@ -236,13 +237,12 @@ PACKAGES and their propagated inputs."
(wrap-program git-se*
`("PERL5LIB" ":" prefix
,(map (lambda (o) (string-append o "/lib/perl5/site_perl"))
- (delete-duplicates
- (list
- ,@(package-propagated-input-refs
- 'inputs
- `(,perl-authen-sasl
- ,perl-net-smtp-ssl
- ,perl-io-socket-ssl)))))))
+ (list
+ ,@(package-propagated-input-refs
+ 'inputs
+ (list perl-authen-sasl
+ perl-net-smtp-ssl
+ perl-io-socket-ssl))))))
;; Tell 'git-submodule' where Perl is.
(wrap-program git-sm