summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 21:11:56 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 23:20:39 -0400
commit629f4d2e6e04ce831a5b2c066d7a4d2d3281d3a7 (patch)
tree7b013c977eff48ae45fa0a2e6d912bfc1b0dbed9
parente170571887dc072edae8b197527921c47743c62c (diff)
downloadguix-629f4d2e6e04ce831a5b2c066d7a4d2d3281d3a7.tar.gz
guix-629f4d2e6e04ce831a5b2c066d7a4d2d3281d3a7.tar.xz
gnu: gcc-5.1, gcc-toolchain-5.1, libstdc++-doc-5.1: Rename to *-5.
This reflects the new version numbering scheme for GCC 5 and up. See <https://gcc.gnu.org/develop.html>. * gnu/packages/gcc.scm (gcc-5.1): Rename to ... (gcc-5): ... this. (libstdc++-doc-5.1): Rename to ... (libstdc++-doc-5): ... this, and use gcc-5. * gnu/packages/commencement.scm (gcc-toolchain-5.1): Rename to ... (gcc-toolchain-5): ... this, and use gcc-5. * build-aux/hydra/gnu-system.scm (%core-packages): Use gcc-5.
-rw-r--r--build-aux/hydra/gnu-system.scm2
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/gcc.scm6
3 files changed, 6 insertions, 6 deletions
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index 556dd7ac2e..b537aa7b1d 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -101,7 +101,7 @@ SYSTEM."
;; Note: Don't put the '-final' package variants because (1) that's
;; implicit, and (2) they cannot be cross-built (due to the explicit input
;; chain.)
- (list gcc-4.8 gcc-4.9 gcc-5.1 glibc binutils
+ (list gcc-4.8 gcc-4.9 gcc-5 glibc binutils
gmp mpfr mpc coreutils findutils diffutils patch sed grep
gawk gnu-gettext hello guile-2.0 zlib gzip xz
%bootstrap-binaries-tarball
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d3f239f5f7..74c3f304af 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -830,7 +830,7 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
(define-public gcc-toolchain-4.9
(gcc-toolchain gcc-4.9))
-(define-public gcc-toolchain-5.1
- (gcc-toolchain gcc-5.1))
+(define-public gcc-toolchain-5
+ (gcc-toolchain gcc-5))
;;; commencement.scm ends here
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index d0a92786ff..6d6101b0fe 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -331,7 +331,7 @@ Go. It also includes runtime support libraries for these languages.")
"0zmnm00d2a1hsd41g34bhvxzvxisa2l584q3p447bd91lfjv4ci3"))
(patches (list (search-patch "gcc-libvtv-runpath.patch")))))))
-(define-public gcc-5.1
+(define-public gcc-5
(package (inherit gcc-4.9)
(version "5.1.0")
(source (origin
@@ -604,8 +604,8 @@ using compilers other than GCC."
(define-public libstdc++-doc-4.9
(make-libstdc++-doc gcc-4.9))
-(define-public libstdc++-doc-5.1
- (make-libstdc++-doc gcc-5.1))
+(define-public libstdc++-doc-5
+ (make-libstdc++-doc gcc-5))
(define-public isl
(package