summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-10 14:58:09 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-20 11:50:43 +0200
commitd05c6da05d99275176c8d0e2c9d4aadecefbee9c (patch)
tree2bcc06c76930f277e4d8d9ad0b3d4a6a6b78b939
parentaaf625b8dc9a6d4d3f257af9f6db47fa9f414ee9 (diff)
downloadguix-d05c6da05d99275176c8d0e2c9d4aadecefbee9c.tar.gz
guix-d05c6da05d99275176c8d0e2c9d4aadecefbee9c.tar.xz
gnu: Add python-gridmap.
* gnu/packages/python.scm (python-gridmap, python2-gridmap): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9550f0d4c6..4962a57a2f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3290,6 +3290,37 @@ Python language binding specification.")
(define-public python2-drmaa
(package-with-python2 python-drmaa))
+(define-public python-gridmap
+ (package
+ (name "python-gridmap")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/pygridtools/gridmap/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1gzjg2k6f14i1msm2b0ax8d9ds1hvk6qd5nlaivg8m4cxqp4cp1x"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-drmaa" ,python-drmaa)
+ ("python-pyzmq" ,python-pyzmq)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/pygridtools/gridmap")
+ (synopsis "Create jobs on a cluster directly from Python")
+ (description
+ "Gridmap is a Python package to allow you to easily create jobs on the
+cluster directly from Python. You can directly map Python functions onto the
+cluster without needing to write any wrapper code yourself.")
+ (license gpl3+)))
+
+(define-public python2-gridmap
+ (package-with-python2 python-gridmap))
+
(define-public python-ipython
(package
(name "python-ipython")