summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-07-21 17:04:10 +0300
committerAlex Kost <alezost@gmail.com>2015-07-21 20:42:06 +0300
commitd2eb275a6e990396d064f2d2ab6e7137e5808845 (patch)
tree4106ee47c75c116637a9471d4e5bc0409d182d1e
parent8dc797fa28d237f30979166bf924c7919d12f88d (diff)
downloadguix-d2eb275a6e990396d064f2d2ab6e7137e5808845.tar.gz
guix-d2eb275a6e990396d064f2d2ab6e7137e5808845.tar.xz
gnu: man-db: Pass --with-col to configure.
* gnu/packages/man.scm (man-db)[inputs]: Add 'util-linux'. [arguments]: Add '--with-col' to configure flags.
-rw-r--r--gnu/packages/man.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 3173fac176..8ebe4ac66f 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,8 @@
#:use-module (gnu packages less)
#:use-module (gnu packages lynx)
#:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages linux))
(define-public libpipeline
(package
@@ -82,14 +84,16 @@ a flexible and convenient way.")
(let ((groff (assoc-ref %build-inputs "groff"))
(less (assoc-ref %build-inputs "less"))
(gzip (assoc-ref %build-inputs "gzip"))
- (bzip2 (assoc-ref %build-inputs "bzip2"))
- (xz (assoc-ref %build-inputs "xz")))
+ (bzip2 (assoc-ref %build-inputs "bzip2"))
+ (xz (assoc-ref %build-inputs "xz"))
+ (util (assoc-ref %build-inputs "util-linux")))
;; Invoke groff, less, gzip, bzip2, and xz directly from the store.
(append (list "--disable-setuid" ;; Disable setuid man user.
(string-append "--with-pager=" less "/bin/less")
(string-append "--with-gzip=" gzip "/bin/gzip")
(string-append "--with-bzip2=" bzip2 "/bin/gzip")
- (string-append "--with-xz=" xz "/bin/xz"))
+ (string-append "--with-xz=" xz "/bin/xz")
+ (string-append "--with-col=" util "/bin/col"))
(map (lambda (prog)
(string-append "--with-" prog "=" groff "/bin/" prog))
'("nroff" "eqn" "neqn" "tbl" "refer" "pic"))))
@@ -103,7 +107,8 @@ a flexible and convenient way.")
("gdbm" ,gdbm)
("groff" ,groff)
("less" ,less)
- ("libpipeline" ,libpipeline)))
+ ("libpipeline" ,libpipeline)
+ ("util-linux" ,util-linux)))
(native-search-paths
(list (search-path-specification
(variable "MANPATH")